I know how to do this in Google Spreadsheets, but it seems there's no data moving support for tables in Google Documents at all. (I can't even select in columns)

Does anyone know how to do it?


5 Answers 5


I've tried a lot. You can't move the columns of a table in the Documents of GDocs. However, if you create a column to the left or right or where you want the new column, you can then select the content from the column you want to move, copy, then, and this is important, you have to select the whole new (blank, newly created) column from top to bottom, and paste the material there. Then, delete the old column and the table will re-format the size. Good luck!!

  • 3
    This is still the case in 2020 which seems odd given Google's apparent capability at building web applications...They can build a search engine but you can't move a column in a document!
    – Andy
    Jan 29, 2020 at 14:18
  1. click the column
  2. ctrl-c or command-c to copy
  3. right click column where you want to move it , select "Insert 1 right"
  4. ctrl-v or command-v to paste done.
  • 1
    That might work in Sheets, but that doesn't work in Docs. May 11, 2020 at 1:47

I was unable to move it at first, but if I double click on column name and drag it, I could see a black line border at the left edge of the column and when I drag it across the other columns, I was actually able to move it.

  • 5
    I think you're talking about Google Spreadsheets. I have no trouble moving columns there. The problem is with Google Documents where I cannot even select a whole column.
    – billc.cn
    Nov 24, 2013 at 12:14
  • aren't they both same?
    – pahnin
    Nov 25, 2013 at 15:10
  • 2
    You certainly won't consider Excel and Word the same application, will you?
    – billc.cn
    Nov 25, 2013 at 16:10
  • Okay, so you have a column in document writer, I get it now
    – pahnin
    Nov 26, 2013 at 7:28

Alternative 1. Create a new column and paste the contents into it

As already explained in this answer you can create a new column and then copy-paste the contents from the source column to the new empty column. Finally, delete the no longer wanted column.

To create a new column
Right-click any cell next to where you want the new column to appear and choose either Insert column left or Insert column right. Copy-paste the contents.

To delete the old column
Right-click any cell in the no longer wanted column and (left-)click Delete column.

Alternative 2. Create a Google Stylesheet and link it to Google Docs

The above solution works fine, but I prefer a slightly different method :

  • I create the table in a Google Stylesheet document.

  • Then I link the stylesheet table to the Google Docs document.

Instructions in more detail
In the Google Stylesheet, I (left-)click the cell at the bottom-right of the table. Then I press Shift and keep it down, and hit the left arrow until all columns are selected. Still keeping the Shift down, I press and keep the up arrow down until all columns are selected. 1

Next I press Ctrl+c, then open the Google Docs document, and press Ctrl+v where I want the table. 2

I leave Link to spreadsheet checked and click Paste.

Link the spreadsheet to the Google Docs document.

The table is now linked from Google Stylesheet to Google Docs. This means that whenever I make a change in the Google Stylesheet table, I'm offered to UPDATE the linked table in Google Docs. 3

Google offers to update a linked table when it's changed.


1 There might be other (more elegant) ways to do it, but this works for me.

2 On macOS just press whenever I write Ctrl.

3 For example, in the Google Stylesheet table, I can click a column letter and drag the column to the left or the right whichever I want.


I've just checked and selecting both row and columns is allowed. Right clicking over selected column (or row) shows cut, copy, paste an a few other options. You should check any restriction on your web browser. Maybe trying with another one.

  • Tried Firefox and Chromium under Linux and neither of them supports column selection. Are you sure you did it in document as opposed to spreadsheet?
    – billc.cn
    May 24, 2012 at 17:27
  • I'm positive on a Windows enviroment, since I don't have any Linux desktop around I can't test it. Do you have the same problem using the live demo? google.com/google-d-s/spreadsheets
    – beiro
    May 25, 2012 at 7:31
  • 2
    That's the 'spreadsheet' app of Google Docs. I am using the 'document' app...
    – billc.cn
    May 25, 2012 at 8:27
  • You should try clearning your cache and trying again. I know that I used to have problems with Google Docs in linux and I needed to clear my cache often. It also could be an issue with the size of document combined with the OS. May 25, 2012 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.