I'm using Firefox 10.0.1 with no add-ons or extensions. A few months ago (possibly with a Firefox update?) the markers (the upside down teardrop shaped ones) stopped appearing in Google Maps. I can see that the image "tries" to load there (I see a little square, possibly with the "broken image" icon, flash where it should be), but the markers don't load. I can see the bubble, but no marker.

I've attached an image where you can see the bubble but no marker.

This makes viewing multiple locations on the same map basically useless. Unfortunately I can't test other browsers since this is all I can use at work.

Why aren't these markers showing up and what can I do to fix it?

screen shot


There is a known bug with loading the marker images when you are behind a proxy - I suffer from the same problem. There is a thread on the issue on the Mozilla support pages here, something to do with Firefox not sending the proxy authentication information with the request. There is a Bugzilla issue open for it (now marked a duplicate of another issue) - it alleges that the issue should be fixed in Firefox version 13 (I can't install it to test unfortunately).

Alternatively, Galious in the Mozilla support forum suggests using the Proxy Authentication add-on to solve the problem in the mean time.

  • Thank you! The add-on worked perfectly and my markers are back (I can't install version 13 either). Everyone had useful answers but I'm accepting this one (and awarding the bounty) because your suggestion about the add-on fixed the problem.
    – Jer
    Jun 15 '12 at 13:38

I've no problem with Firefox 13.0 on Mac.

When you click on a marker a new marker image loads and the marker image displayed before you click on it transforms to newly loaded and bigger marker image.

The problem may be Firefox couldn't load bigger marker image from its source. You can inspect this from console that could be accessed from Tools > Web Developer > Web Console.

If you see a line like this includes 200 OK message, may try to update Firefox.

Else if you see it tries to load bigger marker images but response status aren't 200, may try to inspect your network.

Could you give some info about application or code snippets to reproduce this problem.

  • I don't know what you mean by the application or code snippets - I'm just trying to use the Google Maps web site. In any case, I turned on Web Console and I get tons of lines. There are 3 common ones (407 Proxy Authentication Required, 200 OK, and 204 No Content). I'll post these in another comment since there's not enough room in this one.
    – Jer
    Jun 12 '12 at 15:17
  • [11:12:02.072] GET maps.gstatic.com/intl/en_us/mapfiles/markers2/… [HTTP/1.1 407 Proxy Authentication Required 5ms] [11:12:02.895] GET lh3.googleusercontent.com/-7MlW86GJH-Y/T6_f5_C0i3I/AAAAAAAAADE/… [HTTP/1.1 200 OK 19ms] [11:12:03.038] GET maps.google.com/maps/… [HTTP/1.1 204 No Content 78ms]
    – Jer
    Jun 12 '12 at 15:17
  • Finally, I think Firefox is up to date? When I go to About and click Check For Updates, it says Firefox is up to date.
    – Jer
    Jun 12 '12 at 15:18
  • In the first one you've posted, a 407 message, your browser can't access the marker image because of your proxy you or your network have been using. Are you using any proxy? Jun 12 '12 at 18:41
  • We do have a proxy here at work. I can't imagine why it wouldn't allow us to load those markers, but I guess that is the problem...
    – Jer
    Jun 12 '12 at 20:25

There are options to set your own marker graphics, you can try that to make sure it's really not showing up. Try in Chrome and IE as well


For IE10+, I just had to update the icon source location. Worked ok in Chrome.

//updated icon source June 2015
var imgsrc = "http://chart.googleapis.com/chart?chst=d_map_pin_letter&chld=" + 1 + "|00FF00|000000&.png";
var img = new google.maps.MarkerImage(imgsrc);

I solved this problem: The Firefox add-on Ghostery (love it) was the cause. It has a whitelist option; just add the google.com URL and save.

  • 2
    Asker says that they have no add-ons running. I also don't think Ghostery was available when this question was first asked.
    – ale
    Nov 9 '15 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.