19

Gmail now supports multiple rich-text signatures. However it prepends "--" before the signature. Is there a way to disable this?

4
  • 6
    The double-dash before the signature block is a long-standing standard in e-mail.
    – ale
    Jul 9 '10 at 17:06
  • I wouldn't say long standing I would say antiquated. Look at most professional signature blocks from large companies, double-dash is not included.
    – drye
    Jul 9 '10 at 17:47
  • 2
    And I would suggest they're doing it wrong. For one, that convention allows e-mail clients to not included the signature block when quoting for a reply.
    – ale
    Jul 9 '10 at 18:09
  • Interesting. They seem to have another way of detecting signatures and graying them. If you don't enable the Labs feature as Brian suggested than your signature gets turned into the purplish quoted text with the rest of the previous text... right or wrong, I like what the labs feature does better.
    – drye
    Jul 9 '10 at 18:22
25

Yes

In "General" settings, under the signature text box, check the check-box that says

Insert this signature before quoted text in replies and remove the "--" line that precedes it.

3
  • 1
    Thank you! "Signature tweaks by Keith C and Dave C Places your signature before the quoted text in a reply, and removes the "--" line that appears before signatures."
    – drye
    Jul 9 '10 at 17:07
  • @drye: I was very pleased when I found it too :) Jul 9 '10 at 17:07
  • Totally skimmed over that line many many times. That settings page is sooooo cluttered these days. Thanks for mentioning this!
    – balupton
    Nov 4 '13 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.