7

I got mail from Gmail saying someone from a certain IP tried to log-in and it was prevented and that I should reset my password by following the given link if I don't recognise the address.

...We prevented the sign-in attempt in case this was a hijacker trying to access your account...

However, this is not from a hijacker but from an application I set up some time ago. Now it can not access my account. How can I remove the prevention of the sign-in?

  • Why can't you access your account? What's the problem? – Bibhas Jun 21 '12 at 5:04
  • If it’s an app, how about enabling the application-specific password feature? – Alex Dec 29 '13 at 11:12
  • I also have a problem, but the option of "allow access to less secured application" is sisable due google suspected. – Eitan Sep 12 '17 at 17:55
4

You should be able to use Google's Unlock Catpcha to unblock your application. I can't find much official doco on it, but according to this post if you unlock with the captcha logins for the next ten minutes are recognised as legitimate.

  • In fact, I do NOT have full authorization of the application, which, in my case, is sipsorcery. I just checked my sipsorcery account, and it turns out that my google account was set up as sip provider in sipsorcery. However, sipsorcery failed to register into google account, and I guess that google has prevented it to sign in. Any one has a solution for it? – Alert Jun 22 '12 at 4:49
  • It appears Unlock Catpcha does work in my case. support.google.com/mail/bin/answer.py?hl=en&answer=78754 – Alert Jun 22 '12 at 5:21
  • @John, Doesn't doco mean documentary instead of documentation? – Pacerier Dec 7 '17 at 22:46
1

Go into the the message and then, on the bottom right hand corner there should be a button that says details. Click that then choose 'Never show an alert for unusual activity' Then after 7 days it should stop sending you them alerts, in 7 days because they want to make sure that the 'bad guys' did not choose that. Then from then on you shouldn't be getting any more annoying alerts.

1

It's probably an old question, but I think Google has updated it now. You only need to turn on "Allow less secure apps" in your settings.

The most easy way is to click "Review your devices" in the email: when you are asked if you did the sign-in attempt, click "Yes, that was me" and "OK". Then you are given the chance to "Allow less secure apps" (though they don't recommend it)

Look carefully because the link "Allow less secure apps" is pretty small.

0

It is very annoying. I manage several different Gmail accounts from one email client, and I travel. If I forget to connect to my home VPN before I hit "Receive E-mails" it can lock me out of any number of the gmail accounts I receive from. Sometimes it triggers a "web login required" which means exactly that. I have to log in via the web interface and verify "something"...the rest of the recovery email (it shows some of it to help) or get a code on my phone (I have the phone on very few of the accounts). It is annoying to say the least. I ALWAYS access via pop3, so you'd think that Google would be able to see that and stop blocking access with the password via pop3. I may wind up abandoning Gmail completely if they continue to make it less convenient.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.