6

All of a sudden, whenever I open any Google Page now, (whether logged in or not), it appears in the language of Hindi and I have to use Google Translator to Translate into English and use it.

How can I fix this? How can I have English as my default Language and never have any page of Google appear in any other language?

  • In what state are you? What languages do you speak? I'm curious if jquery.uls selects default language better: if you visit this page for test what language do you see in top bar? – Nemo May 2 '15 at 7:02
5

First of all, I recommend you to start with clearing your Google cookies, since I think it can be that Google stores your language in a cookie as well.

After your did that, head over to https://www.google.com/settings/language and select your language. Normally all Google services should be in that language by default then, but I know of some that manage languages by themselves. Like f.e. the Google Play Store.

4

I had a very similar situation, my Google Account default language settings was already set to English; there are 2 solutions to this:

1st Solution, applies to all Google services:

Change the language here: https://www.google.com/settings/language, go from English to another language, confirm then revert to English again

2nd Solution, applies to the current Google service:

Add ?&hl=en to the url and submit

2

If 1st and 2nd solution of Nabil didn't work, verify your language settings in your web browser. In example in Chrome go to:

chrome://settings/languages and check the settings.

See: http://www.wikihow.com/Change-the-Default-Language-in-Google-Chrome

protected by Community Mar 29 '13 at 11:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?