I don't want questions that I answer to appear on my timeline. And I'd prefer not to have to manually hide it every time I answer one.

I remember there used to be a setting to automatically hide all activity from particular services such as Questions. Does this still exist? I couldn't find it.

  • 2
    Tip: Questions is an application who's main goal is to advertise its participants' answers. I.e. if you don't want your answers published: stop answering questions. – Alex In Paris Jul 17 '12 at 16:00
  • I'm not trying to make them user-private, I just don't want them in my timeline. – Taymon Jul 17 '12 at 16:02

You can remove the posts which you are following say for example a Question Post. There are button on the right when mouseover 'Edit/Remove -> Hide from Timeline'.

  • That sounds like the OP would need to act on every one individually, which he/she has already stated is not preferred. – ale Jul 27 '12 at 12:56
  • Accepting this anyway because it appears to be the only way. Le sigh. – Taymon Jul 30 '12 at 20:58

Head over to your "activity log" in your profile page, considering your language is English US look on the right panel which has filters, and you can find at the bottom of the list "apps" just click the word above it "more" and the list will update with more filter options. Head over to the bottom of the list and choose "Questions"

Now for questions with checkboxes you gotta uncheck each check box for each answer on each question, and for questions with one answer only (radial button questions) you have to look on the right of the question frame and click the small arrow and choose "unvote"

I came here to find a solution, ironically I figured it out by myself and helped ya :P Good luck!


In the right hand side menu, there's a section for apps, if you can't find questions there, click on more and find Questions app. Click on small pencil icon and then to settings.
You can set all the settings related to the app here, like who can see your activity, or if the app is allowed to post activity or not etc.

  • I don't see Questions listed, even in the full apps list. – Taymon Aug 21 '12 at 6:46

You know the box that contains all those answers…as in it says your name and that you answered certain questions etc, well under your name where it says the date and the month: CLICK ON THAT.

It will take you to another page with the same box in the middle of the page…Then just click on the edit button (The one that looks like a pencil) and select hide from timeline. That should work for all of them. To ensure that it worked, go and see your profiles/timeline in the 'View As' option and that activity box should not be there. Hope it works for you.


Click on the following link and then hide the question(s) that you want to hide from your Timeline

  • This does not address the asker's desire to not have to manually hide individual questions. – ale Nov 13 '12 at 13:29

I just figured it out myself.

This opens up all the questions you've answered, and that you allowed on your Timeline. Pretty easy to select each and then on the top right, select the small round button on the outside (the other is the Public button), and then in the options, either Unvote or Hide from Timeline.

Good luck.

  • 1
    This is the same as Mohamed's answer. – Taymon Jan 15 '13 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.