Why does this work:


And so does this:

(Note: loads YouTube video) http://www.google.com/search?q=azure+ray+rise&btnI=I%27m+Feeling+Lucky

But this doesn't:


Nor does this:


Can websites/domains disable Google's "I'm Feeling Lucky" feature? Or what?


As mentioned in the comments, when both search queries that do not work using those URLs are typed in manually on the Google homepage 'I'm Feeling Lucky' does work (note that you will have to disable Google Instant to use the button). However, when I copy the resulting Google URL (captured using Firebug) and paste that in the location bar it still doesn't work. An example full URL is:


  • It worked for me when I copied the search terms into a new search and clicked "I'm Feeling Lucky".
    – amiregelz
    Commented Aug 11, 2012 at 12:01
  • @amiregelz interestingly enough that works for me as well, however when I copy the resulting Google URL (captured using Firebug) and paste that in the location bar it doesn't work.
    – Bruce van der Kooij
    Commented Aug 11, 2012 at 17:54

1 Answer 1


I just noticed the question "Google's “I'm Feeling Lucky” URLs no longer working?" under related in the right navigation bar. The second answer to that question offered a working solution: add the querystring parameter sourceid=navclient (navclient is a reference to the Google Toolbar):



Apparently having your Referer set to *.google.com also works. The links in this post of mine on the Google Product forums all work as long because the referer being sent with the request.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.