I want to send a zipped file to someone with a Gmail account, but it doesn't arrive. I get a Delivery Status Notification (Failure).

So how can you configure Gmail to receive zip files?

PS the file doesn't contain a virus or other malware.

  • Perhaps the zip is too large? IIRC the maximum attachment size for GMail is 25Mb. – pritaeas Aug 15 '12 at 14:09
  • No, I tried several, one as small as 100K. But apparently, Gmail blocks incoming ZIP files by default. And I just want to know how to change that. The receiver already added me as a contact, but that didn't do the trick. – Mr Lister Aug 15 '12 at 15:12
  • 3
    are you sure that the compressed file has not one of this extensions: "ade", "adp", "bat", "chm", "cmd", "com", "cpl", "exe", "hta", "ins", "isp", "jse", "lib", "mde", "msc", "msp", "mst", "pif", "scr", "sct", "shb", "sys", "vb", "vbe", "vbs", "vxd", "wsc", "wsf" y "wsh". All this files are blocked in Gmail, even if they are compressed – elunicotomas Aug 15 '12 at 16:40
  • 1
    And how do you unblock them? – Mr Lister Aug 15 '12 at 18:35
  • I know with rar that you can encrypt the filenames. Perhaps that and setting a password may work. Never tried this though. Or perhaps you can upload it to google docs. – pritaeas Aug 15 '12 at 19:41

Google blocks a specific set of executable file types. Zip files are only blocked when they contain any of these file types or if they are encrypted and contain another zip file [source].

You can continue to send zip files by:

  • Not sending zip files containing executable files
  • Renaming the extensions for the executable files or the zip files (which then needs to be renamed back before use)

Some of the executable file types that are currently blocked include:

.ade, .adp, .bat, .chm, .cmd, .com, .cpl, .dll, .dmg, .exe,
.hta, .ins, .isp, .jar, .js,  .jse, .lib, .lnk, .mde, .msc,
.msi, .msp, .mst, .nsh, .pif, .scr, .sct, .shb, .sys, .vb,
.vbe, .vbs, .vxd, .wsc, .wsf, .wsh

The compression formats that are evaluated include:

.zip, .tar, .tgz, .taz, .z, .gz, .rar, .bz2
  • 3
    As of today, this no longer works for me. Nor can you download attachments previously sent to/through Gmail this way. Posted a product question here: productforums.google.com/forum/#!mydiscussions/gmail/… – mcw Oct 9 '14 at 19:31
  • @Silveri, You don't have to rename the zipped files. Just rename the .zip file itself to .txt, .pdf, .foobar, or .*[nothing]*. – Pacerier Nov 19 '15 at 21:24
  • 1
    @mcw0933, This still works. But you are asking a different question, see Phat's solution for your question. – Pacerier Nov 19 '15 at 21:24
  • 4
    .js extension is also blocked – joseantgv Dec 5 '17 at 8:25
  • 1
    @Pacerier it no longer works – joseantgv Dec 5 '17 at 8:30

There are many ways to get this but I finally found a quick way to get blocked file from Gmail. Instead download all mail to your computer and search again mails you want to download.

  1. Create a new label in gmail (ex: Downloads).
  2. Labels mails that you want to download with new label (Downloads in my case).
  3. Go to https://www.google.com/takeout. Then remove all option except Gmail and choose only label Downloads. Next, next to final steps.
  4. Finally, extract .zip file downloaded from step 3, you will get .mbox file. import it to Outlook or ThunderBirds.
  • 1
    The Asker is trying to send a zip file, not download one that was sent to them. – ale Dec 31 '14 at 11:42
  • 4
    even if this isn't what the asker wanted, it turned out to be very helpful to me today, so i'm grateful :) – pestophagous Feb 19 '17 at 2:21
  • Works great! I had a tar.gz file containing source code I had sent to an employer a few years ago. I wanted to review what I had sen but GMail blocked me from downloading a tar.gz file. I followed these directions, then used Apple Mail client, File > Import Mailboxes..., selected the GMail downloaded "takeout" *.mbox file and all is good. Thank you! – Ed of the Mountain Jul 30 '18 at 18:17

I have had the same problem. My solution was to change the file name from .zip to .zzz.

The recipient then merely changes the file name back to .zip.

Recently however, My zip files have gone through. (I accidentally forgot to change the file name.) Maybe Google has relaxed their policy.

  • 5
    " Maybe Google has relaxed their policy." More likely your zip file just didn't contain one of the blocked file types. – ale Dec 31 '14 at 17:56

Google blocks zipped files only if they contain executable (or other not allowed extensions) files. That's why some zip are accepted while other zips are blocked.

  • Perhaps you can add a refence to your question, with the not allowed extensions? – Jacob Jan Tuinstra May 17 '13 at 8:25
  • 1
    As of today Google blocks ZIP archives with JPEG files. – Ivan Nikitin Dec 13 '18 at 9:35

Google now blocks ZIP files containing executable files. You can transfer these files by uploading to Dropbox (or any file sharing service), and then sending a link.

  • 2
    Or Google Drive. Or Box. Or Copy. Or any of a thousand file sharing services. – ale Jul 14 '15 at 15:29
  • 1
    @AlE. yes... basically any filesharing service. I happen to use dropbox and it's been pretty good. – angryITguy Jul 14 '15 at 22:47
  • @giulio, Don't have to use Google Drive. Just rename the .zip to something else. – Pacerier Nov 19 '15 at 21:20
  • @Pacerier yes you can do that. And you will have defeated Google's filtering rules, but you have to change the file name. Google will eventually read the file contents and filter on that to. All well and good, but google drive is the suitable platform for file storage. Have to agree with Google, in that email is not meant to be a file storage system. – angryITguy Nov 20 '15 at 1:13
  • @giulio, You mean that eventually "Just rename the .zip to something else" will not work? But if they wanted to stop that, they would have done that already..... – Pacerier Nov 23 '15 at 21:21

Create a new ms Word document. Change the extension to zip. Open the file using zip You will see that the internal structure of a Word file is a zip format. Add now your folder you want to add. Save the zip file. Change te extension back to docx

Now you can send it using Gmail

  • For all that, you wouldn't even need to create the document first. Just rename the extension as mentioned in @Silveri's answer. – Andrew Lott Jan 6 '16 at 2:15

Configure your MS Outlook with gmail account. You will be able to send and access all attachments.


Not the answer you're looking for? Browse other questions tagged or ask your own question.