20

Possible Duplicate:
How to extend series of dates in Google Docs?

In Excel, when you enter a date and hold right click button + shift and move the mouse, it will create dates.

Is there a way to create a column of date easily with Google Spreadsheets like with Excel?

31

In both Excel and Google Spreadsheet...

  1. Enter a date in a cell
  2. With LEFT mouse button, click (and hold) square handle in bottom right corner of cell.
  3. Drag the selection to cover all cells you wish to be dates.
  4. Release mouse button.

However, Google Spreadsheet will fill the selection with the same date, unlike Excel that fills a sequence of consecutive dates.

To make a sequence of dates in Google Spreadsheet, complete the first two cells manually and select these two cells to drag over the required range of cells. Google Spreadsheet then continues the sequence.

UPDATE 3-Jun-2020: Not sure when this behaviour changed, but you now only need to select a single date before dragging to create a sequence of dates increasing by 1 day. In this respect, the behaviour is now the same as Excel.

Note that you do need to make sure you have selected the appropriate locale and date format for this to work as intended. See the following WebApps answer for more detail on this.


In Excel, enter a date, hold right click button + shift and move the mouse to create dates

This does not work for me in Excel?

| improve this answer | |
  • 3
    Ah, you wish to create a sequence of dates... 2012-09-04, 2012-09-05, etc... Then you need to manually create the first two entries and select these two entries before dragging the selection. – MrWhite Sep 4 '12 at 10:12
  • 3
    This only works if the locale (File->Settings) of the document is correct AND all your dates are in the correct format. Google assumes American date formats, rather than the format used by the rest of the planet. – Dr Rob Lang Jan 30 '14 at 10:56
  • 3
    That doesn't work for me, even after using the correct locale and making sure the format is right. Only the YEAR of the dates in question is changed, not the day and month, which obviously should change first. – grunwald2.0 Feb 1 '15 at 13:05
  • 1
    @loretoparisi There must be something different in your config/formatting/locale or something that results in that behaviour? Whatever format/setting I use, it always increases by +1 day. – MrWhite Sep 8 at 16:58
  • 1
    @MrWhite confirmed, it must be set the right locale, that is not automatic: webapps.stackexchange.com/a/89846/122486 – loretoparisi Sep 8 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.