I have a 25Mbps Comcast (cable) connection that gives me 30Mbps throughput, measured with active torrents (not while playing YouTube videos obviously). When viewing YouTube videos, they pause → buffer → play → pause → buffer etc etc. This happens on our wired PC, wired iMac, wireless MacBook, iPad and iPhone. Whether I have 1 video playing or 20, they all play the same speed/rate it seems. Never has a single YouTube video even put a dent in my bandwidth utilization (measured at the router) so I know it’s more than likely not my connection.

Probably unrelated, but I get 20-25ms latency to www.youtube.com with 0 packet loss. Here is my Speedtest.net test:

Speedtest.Net Test

Is there a way to force YouTube to utilize more of my unused bandwidth to reduce the pauses and provide a better viewing experience?

  • latency has got nothing to do with bandwidth & throughput Sep 13, 2012 at 4:22
  • hence the "Probably unrelated" note
    – mxmissile
    Sep 26, 2012 at 16:09

4 Answers 4


One way or another the bandwidth will be throttled by either your Internet Service Provider and/or the site itself.

Imagine everyone with your current speed (or higher) all trying to load videos at once!

  • Would never expect them to use my full pipe, but to have it use "more" of my avaialbe bandwidth would help greatly. Even just slightly more.
    – mxmissile
    Sep 13, 2012 at 13:46
  • @mxmissile lower your quality settings or let the video pre-load before viewing it. Sep 25, 2012 at 18:46

Try YouTube "Feather" Beta

This is an opt-in beta for "Feather" support on YouTube. The "Feather" project is intended to serve YouTube video watch pages with the lowest latency possible. It achieves this by severely limiting the features available to the viewer and making use of advanced web techniques for reducing the total amount of bytes downloaded by the browser. It is a work in progress and may not work for all videos.

This is part of YouTube's ideas incubator, TestTube

  • Note: Feather is no longer available.
    – Shaz
    Jul 8, 2015 at 1:59

Do this easier method:

  1. Go to RUN and type gpedit.msc it will open a dialog box.
  2. Go to Local computer policy > computer configuration > administrative templates > network > Qos Packet Scheduler.
  3. On the right hand side you will find "Limit Reservable Bandwith". Open it.
  4. Enable it and set the percentage to zero.
  5. And you have your 100% bandwidth.

I applied this tweak last week.


You can't - not directly, anyway. YouTube will automatically adjust the playback quality depending on your connection to the YouTube servers. Even if your overall connection seems good, your connection to YouTube in particular may not be great - usually this is a problem with the ISP.

There's a caveat here, though. Judging from your speedtest.net image, you are using ComCast. They are well known for using their own intermediate caching servers for YouTube, presumably to decrease their own costs. You're not actually connecting to YouTube, you're connecting to ComCast's servers - which are known to cause playback quality issues.

This thread has a number of methods to bypass these caching servers, depending on your operating system. I'm not sure if this still works the same (and since I don't use ComCast, I can't test it), but it should at least provide a starting point for solving the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.