9

How can Google Docs Spreadsheet be prevented from expanding to the size of the cell contents?

Example:

The cell expands vertically to fit the cell contents:

enter image description here

The cell expands horizontally to fit the cell contents:

enter image description here

Would like to see something like this instead:

enter image description here

5

There's a "wrap text" icon in the button bar just below the menu -- 4th button from the right, between the "merge cells" and "functions" buttons.

enter image description here

By default, text wrap is enabled. You can disable it for specific cells, a range of cells, entire rows, entire columns or the entire spreadsheet. Select the relevant cells (or column or row header or the top left corner for the entire spreadsheet), then just click the "wrap text" button to disable it.

  • 2
    I must have a newer version because this does not work. – user107270 Nov 2 '15 at 23:43
  • 1
    This doesn't work in all situation. Specifically if the form enterer added 'enter' in their form to auto-populate the cells. In that situation then you cannot shorten the height of the cells. No matter which wrap text offering you selected. This is true as of March 18th, 2018. – John Mar 18 '18 at 18:13
2

enter image description here

Step 1: Click here to select all cells.

Step 2: Adjust any one cell height (All cell will have the same height which you will define).

1
  1. Select the cell.
  2. Select in top menu Format > Text wrapping > Clip.

This will give you what you wanted.

  • This is what I was looking for. – Bikram Aug 26 at 8:54
1

Little tardy to the party but I was struggling with the same issue today. I don't think the other answers are getting to the root of your problem. Here's what I just figured out:

It looks like Row Height is set to expand to fit the data, by default.

In contrast, Column Width is set to a specific width, in pixels, 100 by default.

To set Row Height to a specific value, right click on the row header (you can select multiple rows at a time) and select "Resize row..." Then select the "Specify row height" option, instead of "Fit to data."

Step 1

Step 2

A specified row height will override text wrapping settings. Any information that's wrapped below the specified height will not be visible.

Hope this help!

  • This is the only solution that worked for me for text with multiple paragraphs. The only downside seems to be that it has to be done for individual rows (or I'm blind and don't see the option to apply it to a row-range). – user2384366 Dec 5 at 21:20
  • A slight correction to my previous comment - there IS a way to set the size of multiple rows. Resize one empty row => Select it and copy => Select multiple empty rows and paste. That way, the row height should be preserved. – user2384366 Dec 5 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.