15

Okay, this is messed up. I opened up my budgets spreadsheet as I do every week, and realized that I could only edit 1-2 cells before everything would freeze up. Inspecting the UI, I found a tiny lightning bolt in a circle next to the title whose hover text reads "You are offline". No Google, I'm not. This is in Chrome, which appears to have updated itself today.

I uninstalled the Google Drive desktop program (had been meaning to anyway after reading this scary article) and also removed Google Drive from the list of apps on my new tab screen. No luck.

Other details:

  • It seems to apply to other spreadsheets too, but not text documents.
  • It seems to work fine in Firefox
  • Chrome is version 22.0.1229.94
  • I don't have a solution, but I've seen the same thing. Obviously the "heartbeat" being sent back to the Google servers isn't returning (on time) and so the client drops into offline mode. I've not been able to find a consistent time, place, or circumstance for when this happens. – ale Oct 24 '12 at 12:53
  • 1
    I just experienced this not too long ago with the Drive client itself. Here, I opened the Dev console and can see that a DNS lookup is failing. I think there's a bug related to the "0." hostname. I've seen this before and the following fixed it then and now: From: superuser.com/questions/203674/how-to-clear-flush-the-dns-cache-in-google-chrome "Navigate to chrome://net-internals/#dns and press the "Clear host cache" button." – rainabba Jul 23 '14 at 21:12
  • I am hitting this when I try to edit a lot of documents at once. I'm trying to migrate a few hundred documents so I'm opening up 20-30 docs at once, pasting content into each, etc... only to have it start having these issues! – Michael Apr 24 '18 at 17:53

13 Answers 13

5

I had this same problem for about a month.

Today I had the idea to disable the image blocker extension that I had installed for Chrome. Drive started working again immediately. I wish I had realized this earlier!

| improve this answer | |
  • I disabled all extensions and the problem disappeared. Thanks for the suggestion! – qris Aug 27 '16 at 17:03
2

I found it beneficial to investigate whether or not the computer's security software is a factor. For me, Kaspersky automatically updated in such a way that inhibited my ability to edit in Google Docs. It was the result of an 'encrypted connection scanning' issue.

This site was helpful: http://www.htgsd.com/information-technology/google/google-drive-trying-to-connect-to-edit-offline-turn-on-offline-sync-when-you-reconnect/

I'm wondering if others might experience a similar problem even with different software. I hope everyone finds their remedy.

| improve this answer | |
  • Thank you! I saw that requests to 0.docs.google.com were failing with no reason in Chrome. I tried whitelisting it in adblock, but it wasn't until I disabled Encrypted Connection Scanning in Kaspersky that it came right. – Wogan Nov 28 '15 at 21:01
1

It seeeeems that this is no longer an issue thanks to some update to something. Fingers crossed.

| improve this answer | |
1

It just happened to me and turned out to be script blocking.

If you are using ScriptSafe or any of the other script blocker - make sure scripts originating from 0.docs.google.com (and possibly others, as the implementation changes with time) are marked "allowed".

Needless to say - make sure the scripts you allow are safe before you allow them...

| improve this answer | |
  • Interesting. I don't use any kind of script blocking, so it must have been something else causing it for me... – MalcolmOcean Mar 14 '13 at 4:34
1

Had the same problem, found the solution here : https://support.google.com/drive/thread/9501291?hl=en&msgid=21314289

It's this little switch that caused the whole "Offline" problem (in the parameters of Google Docs here but can be in any Google app) : switch offline parameeters Google Docs, Sheets, etc.

It was on, an the moment I switched it off, everything came back.

| improve this answer | |
0

This is probably Google Docs/Drive's issue. I have the same issue and have tried turning off the offline editing but no luck. Since the offline mode is only supported by Chrome for now according to Google support doc, the easiest walk around is to use IE/Firefox/Safari.

| improve this answer | |
0

I had this problem with Firefox.

I did this: Tools → options → security

I had Warn me when sites try to install add ons checked.

I added an exception for 0.docs.google.com and now it seems to be working ok (for now).

| improve this answer | |
0

If you have another device like an iPad or 2nd computer, try using the Docs app and make some kind of change to the document. For whatever reason, it resolved my problem. I just went into the document on my iPad, pressed the spacebar, checked on my computer, and I was back online.

| improve this answer | |
0

Try making a copy of your spreadsheet. If you have other spreadsheets linked to your original spreadsheet, you can use a utility such as https://www.ignaciobaixauli.com/aplicaciones/aplicaciones-con-google-apps-script/replaza-textos-en-google-spreadsheets to change references to your original spreadsheet

| improve this answer | |
0

I had AdBlock Plus and AdBlocker Ultimate. When on, the document said I was offline. When off, it said I was online. I think ad blockers play a role.

| improve this answer | |
0

If you're using Chrome, try clearing out any temporary files associated with Drive. You will lose any unsynced changes via this method.

Steps:

  1. With a Doc site open, press "Ctrl + Shift + j or i or F12" (MacOS: " + Option + i"). The "Developer Tools"/"DevTools" window should pop-up.
  2. Navigate to the "Application" tab at the top.
  3. Underneath "Application" in the left-hand panel, select "Clear storage".
  4. In the primary panel on the right-hand side, click the button at the bottom labelled "Clear site data".

Note: This method should work with any browser, but I have only tested in Chrome. If you're stuck in a sync error loop, try opening your Doc/Sheet in an Incognito tab, and duplicating and then deleting the Page/Sheet you believe may be responsible for the sync error.

| improve this answer | |
0

i also had same problem but after disable my avira web security google drive working normal again

| improve this answer | |
-1

Check that Google Sync is working properly. Or any messages in Google Sync.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.