Using Google Chat in Gmail it is impossible to select all the text in the conversation. I often want to quickly copy the text from one conversation and email it or instant message it to another contact. The problem is that the small chat windows, even if you pop them out and expand them to the screen's full height, will not show the entire text of a long conversation. You can select the immediately visible text on one screen, but while you are dragging and highlighting, the screen will not automatically scroll when you reach the top or bottom edge.

Also, when you try to highlight some text and then maybe scroll and shift select some more text that does not work either. As soon as you start scrolling the currently highlighted text is deselected. So effectively, the most text you can select at one time is as much as you can fit on one screen.

Of course it's always possible to go to your chat history and look up the full text of the conversation there, but that is a very cumbersome workaround for something that should be as easy as Select All, Copy, Paste.

Has anyone found a better way?

I love Gmail and Google Chat, but is there a way to make copying the text in a conversation suck less?

  • Have you looked at the is:chat search option ? – phwd Jul 13 '10 at 21:39

You mentioned this is not ideal, but with a few additional tricks it is not so bad:

  1. Hover over contact in list
  2. Video & More
  3. Recent Conversations
  4. Highlight portion you want to forward(With the "Quote selected text" Labs feature)
  5. Forward Button
  6. Add Recipients
  7. Send
  • eh, it's not really an intuitive or quick workflow, seems like a lot of steps just to copy some text. but you're right, the Quote selected text lab feature is an improvement. – Tion Oct 14 '10 at 15:23

Hey Update! I recently noticed that selecting text, then scrolling does not deselect your text anymore! (at least when using the Google Chrome browser, haven't tested others)

This makes it possible now to highlight some text, scroll up/down, shift + select to highlight all the text in between. Then copy works with either Ctrl+C or right click!

I think Google has been reading our posts!


I have this same issue. The best tip I have is to always use right click copy instead of ctrl+C.

Not the answer you're looking for? Browse other questions tagged or ask your own question.