6

I'm fed up with the sensationalized stories from http://www.dailymail.co.uk and would like it not to appear in my news search results. I found a way to eliminate it from the news.google.com aggregation when I'm logged into my Google account.

However, if I search for topics in the News section, that site shows up in the results. I realize I can do a -site:dailymail.co.uk, but I tried adding it to blocked sites in general search preferences (requires login to Google), but that didn't work.

Here's a related question that implies blocking sites doesn't always work.

  • 1
    I can't reproduce the problem, but did you clear your cookies/cache recently? – Hydra Dec 27 '12 at 6:19
  • 1
    @Hydra your comment led me to test further. It seems that it's a problem with Google multiple sign-in. If I'm signed into more than one account, even though I use the account which has blocked dailymail.co.uk for the news search, the search ignores that setting. The solution is to sign out of all accounts and only sign into the the account which has blocked the site. – Fuhrmanator Jan 27 '13 at 19:28
  • Not really an answer to the question, but I've had the same problem... Google is really annoyingly pushing up Mail and Express, I wonder why... Anyways, I found out that duckduckgo's newsfeed is not so much worse. Seems to come with a bit of delay, but on political topics is so much better without all the clickbait nonsense. – mapto Nov 7 '18 at 10:41
-2
  • First unsubscribe from the website you registered
  • Sign in gmail
  • Go to google.co.in/preferences
  • Click Block unwanted sites Try this..
  • Perhaps it wasn't clear in my question, but I already tried this. The site is "manually blocked" in that list, but News still shows its articles in the feed. – Fuhrmanator Jan 21 '13 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.