4

This question already has an answer here:

When using Google Maps the web often displayed in Vietnamese. (I live in Vietnam.)

I want it default to be English. How can I do that?

marked as duplicate by ale, serenesat, jonsca Feb 15 '18 at 23:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Which browser are you using? Do webpages usually display in English, and using Google Maps causes them to change to Vietnamese? Which language does Google Maps display in? Need some more info to provide an answer. – nitrl Jan 11 '13 at 6:11
  • @nitrl Hi there, this may help us. When I add hl=en, I got what I want but that won't remain as default and I'm not very interested in adding that all the time. So my answer is Chorme browser, and yes using Google Maps causes the change. English is the language of my browser as all other software I use here. – Nam G VU Jan 11 '13 at 6:50
  • 1
    Sounds like Google Maps is auto-detecting your location and then applying your current location to Chrome. Since there's no way to disable auto-detection of location, I can't think of any way to resolve the issue. – nitrl Jan 11 '13 at 7:34
  • @nitrl Yeah. And this is so annoying – Nam G VU Jan 12 '13 at 9:09
  • [Promoting my simple chrome extension (:] which will allow you to pick google maps language: chrome.google.com/webstore/detail/google-maps-language-pick/… – ozma Mar 10 '17 at 16:19
4

I have had same problem. The solution is to add a language hint to the URL. Example:

https://maps.google.com/?hl=en

(The "en" is the two-letter code for English.)

  • 1
    This doesn’t change the default language. – fuxia Oct 13 '13 at 2:34
  • indeed, default is at google account settings (not at search settings option that maps menu has btw on the web) and it seems to ignore browser preferences. So this is a nice trick for developers mostly who want to redirect to some map in a specific language – George Birbilis Jul 5 at 10:32
3

The only way you can change the language of Google Maps is through your Google Account settings. Click on your email address on the top right hand corner and select Account. In the destination page, there is an option under Language and choose English (US) from the drop down.

Screenshot

  • I did this already and long ago. But the Google's sites are always automatically switch back to Vietnamese – Nam G VU Jan 12 '13 at 9:09
  • That is weird, because I am also using a different language than the default and it works perfectly. Did you check your cookies settings? – Hydra Jan 12 '13 at 10:50
  • How can I check the cookies? – Nam G VU Jan 13 '13 at 16:39
  • Like for example, is your browser blocking cookies from google.com, or is cookies disabled? Afaik Google uses cookies to store your language preferences. – Hydra Jan 14 '13 at 13:21
  • I had to change my language to Japanese and then change it back to English. – Amil Mar 29 '14 at 10:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.