I am the organization admin for our Google Apps domain. I have the following pertinent settings configured:

External Sharing options for primary calendars - Share all information, but outsiders cannot change calendars

Internal Sharing options - Share all information

External Sharing options for secondary calendars - Share all information, but outsiders cannot change calendars

However, it seems nobody in my organization (not even myself) can share a calendar outside the organization more than just free/busy info. I'll add an external user with "See all event details" permissions, but they get reduced to only free/busy info when they're actually put on the ACL. There's a drop-down on their line, but none of the other options are there.

Is there something I'm missing? Why else might I not be able to share my full calendar details outside of my organization?

5 Answers 5


If this is happening for all users in your Apps Domain, have you checked the parent sharing settings?

The issue is probably that you have set all calendars to inherit parent settings from the Admin account. In this case you can change the Admin account settings to allow all users within the domain to share event details with people outside the org.

Here's a link to the help article on how to manage the domain-level settings. Relevant sections below:

In the Org Settings tab, select the organization for which you want to set calendar sharing options.

Select the top-level organization to enforce the same settings for your entire organization. You can also specify different settings for each organizational unit. If you have a lot of organizations, click the + button to expand your options.

Under Settings in the left column, locally applied means that the settings are not inherited from the parent organizational unit. (Settings at the top-level organization are always locally applied.) Inherited means that the settings are taken from the parent.

In the External Sharing options for primary section, select how you want to allow users to share their primary calendar outside your domain:

  • Only free/busy information (hide event details): Users can allow people outside your domain to know when they are busy or available, but event details are hidden. Private addresses are hidden from users' calendars.
  • Share all information, but outsiders cannot change calendar: Users can share their calendar information with people outside your domain. This includes guest list, location, and description. Private addresses are hidden from users' calendars.
  • Share all information, and outsiders can change calendars: Users can fully share their calendar information with people outside your domain. This includes guest list, location, and description. Private addresses are displayed.
  • Share all information, and allow managing of calendar: Users can fully share their calendar information with people outside your domain, and they can grant outsiders permission to manage their calendars. Private addresses are displayed. In the Internal sharing options section, select the default internal sharing level for primary calendars.

NOTE: There are also internal settings options that you can set within the Admin dashboard, so just fiddle around and see what settings work best for your group.


OnenOnlyWalter's is the prerequisite solution.

However, for those whose problem persists, I think I got what happened, although that doesn't mean there's an easy fix. The only fix is just to recreate the calendar under your desired domain privilege settings which OnenOnlyWater advises on.

I've found that those calendars of mine which weren't offering the other permission options aside from "Only free/busy information (hide event details)" were most likely created at a time when I had unwittingly set my domain calendar privileges to offer just that one option (as a security precaution).

In other words, if your calendar was originally created when your domain settings were in "locked down" mode, then it will remain so permanently, even after attempting the prerequisite solution. In a way, this makes sense.

The only way to fix this -- sadly -- is to create a new calendar (only after adjusting your domain as OnenOnlyWater prescribes) and then go to the old one to transfer all your events - one-by-one - to the new one.

Then after making sure all your events have been transferred, delete the old calendar.

I realized this when I examined the dates when the problem calendars were created. All of them coincided with roughly the same time when I tweaked my app domain sharing settings to be more secure.

  • It's true that changing sharing options in admin console only affects new calendars. However, as of 2015, you don't have to transfer events one by one - you can export them as an iCal file and then import to your new calendar. See support.google.com/calendar/answer/37118 for instructions.
    – Red
    Commented Nov 18, 2015 at 7:28

Google have updated their code on this and it works more smoothly but if you're the admin of a domain and have the admin account opened in one window and the calendar user in another you will need to log out and back in on the calendar user before the changes will take effect.

This also includes if the calendar owner is the admin as well.

I have just run into the same issue and resolved it by logging out/in after finding this post.


This is also a per calendar setting. Each user must explicitly allow others to view event details.

When viewing your calendar, click the gear icon -> Settings -> Calendars -> [your calendar] -> Share this calendar, and select View event details from the drop-down menu.

Note that

Changes in sharing permissions will generally take effect within a few minutes but, in some cases it may take up to 24 hours.


  • I'm not sure I follow. The problem I'm having isn't for per-user calendars (though I should probably check those too). They're for additional shared calendars. Or, is every calendar effectively owned by its creator?
    – Iszi
    Commented Jan 16, 2013 at 15:33
  • I believe so, yes. Not sure what you're meaning by an "additional shared calendar", but someone must have created that calendar. That 'someone' would be the owner. Commented Jan 16, 2013 at 15:51
  • Ok, I'm still not seeing what you're saying then. I'm admin of the whole domain. I should be able to manage sharing permissions for any calendar. When I go through the path you describe, I see the same interface that's been giving me trouble this whole time.
    – Iszi
    Commented Jan 16, 2013 at 16:03
  • Oh, OK. I would still try logging in as the owner of the calendar, and then check the permissions. If that's no different, then I'm out of suggestions. Commented Jan 16, 2013 at 16:06
  • It seems the user that brought the problem to me has found some sort of solution. Not sure if it's yours or not. Will get more details and accept your answer or post another later if I can.
    – Iszi
    Commented Jan 16, 2013 at 16:09

The way I got to it was in admin.google.com > apps > G suite > calendar > sharing settings > External sharing options for primary calendars There you go!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.