2

I'm using Google Apps Standard Edition, however, I noticed the same exact behavior with my Gmail account as well. At first I thought that reminders are sent at odd times for all-day events, but then I found out that they are supposed to be sent at 12AM.

I created 3 reminders with an email reminder set to 0 minutes. Here are the results of when I received the email:

  • For the event at 7/15/10 04:00 PM, the reminder was sent on 7/15/10 04:00 PM
  • For the event at 7/16/10 12:00 AM, the reminder was sent on 7/16/10 12:00 AM
  • For the event at 7/16/10 All-day event, the reminder was sent on 7/15/10 05:00 PM (Incorrect)

These are the email headers for the last event's reminder:

Received: [...] Thu, 15 Jul 2010 17:00:58 -0700 (PDT)
Date: Fri, 16 Jul 2010 00:00:58 +0000
Subject: Reminder: Test @ Fri Jul 16, 2010 

It seems that the 0 minute offset is from UTC instead of my time zone (PDT).

These are the settings that I have set, for both calendars:

  • Google Apps > Domain Settings > General > Time Zone:
    • Default time zone for users at [your domain]: (GMT-08:00) Pacific Time
  • Google Calendar > Calendar Settings > General:
    • Your current time zone: (GMT-08:00) Pacific Time
  • Google Calendar > Calendar Settings > Calendars > [My Calendar] > Calendar Details:
    • Calendar Time Zone: This calendar uses your current time zone: (GMT-08:00) Pacific Time

Other things that I have tried which didn't work:

  • Creating a new calendar.
  • Creating a new Google Apps user.

Any idea what I'm doing wrong and how to fix this?

  • 1
    I've set an email for an event tomorrow in Europe/London time (currently UTC+1) and will see if I can reproduce this... – Jon Skeet Jul 17 '10 at 6:32
  • Aargh, I'm not sure I ever got the email. Will double check. Doh. – Jon Skeet Jul 30 '10 at 6:42
1

Now you can set when you will be notified for All-day events in the Google Calendar Settings.

  1. Go to calendar.google.com in your browser
  2. Click on the gear icon in the upper right and choose Settings
  3. Choose Calendars from the top menu
  4. Select 'Edit notifications' for the calendar you wish to edit this setting for. The first calendar listed will be your primary calendar, and usually the one you'll want to work with
  5. The second setting All-day event notifications allows you to how many days before and at what time you wish to receive the notification
  6. Be sure to click Save before leaving this page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.