21

I changed my Gmail avatar image using:

SettingsGeneralMy pictureChange picture

But it only changed below compose, next to my green available dot and at the top left of each email I send. My old avatar image is still used if I hover my name at the top of an email or if I hover over my new avatar image next to my green available dot.

Edit: I tried clearing my cache and I tried different browsers but neither works.

20

I had the same problem, I had to go into my gmail contacts and delete all the entries for myself. After I did that, voila all fixed. To get to contacts, select the GMAIL button the on top left and a drop down will appear where you can select Contacts. Make sure and remove the contact entries for yourself under "My Contacts" and "Other Contacts".

  • 2
    I had the same issue. When anything would "detect" my picture, it was coming from my card in Google contacts. I would suggest searching for the specific e-mail address (not a name), and just changing the picture on the contact page, rather than deleting the contact entirely. – iynque Nov 4 '14 at 18:20
  • 4
    Doesn't work... – sepehr Jun 20 '17 at 8:34
  • 1
    Deleting the photo works (you don't need to upload a new one) – qaisjp Dec 5 '18 at 17:40
  • 2
    Had the same issue. For me the very old contact picture (and details) was coming from a card under Other Contacts in my Google Contacts. I found a series of cards with different email addresses I've used throughout the years. Deleted all of them and that fixed it. – Bernardo Oliveira Mar 27 '19 at 13:35
2

After searching high and low here is what worked for me:

  • Go to youtube.com
  • Click on your avatar in the top right corner
  • Click the photo to the left of your email address
  • Click the change photo link
  • Select a photo from your computer
  • Click set as profile photo
  • Hold down Ctrl and F5 and the same time (this should update the photo to the right of your email address)

You are done. You do not need to click the Upgrade button.

Go back to Gmail. Do a hard refresh (Ctrl+F5) and the correct photo should be displayed.

  • I found my lingering avatar on blogger.com. That was a tough find since I haven't used that in years. – spstanley Sep 30 '15 at 21:25
  • oh my god, this had been plaguing me for years. thank you thank you thank you! – Neil Sarkar Jun 29 '16 at 7:01
  • Doesn't work anymore, as youtube accounts are now connected to G+ profiles. – sepehr Jun 20 '17 at 8:43
2

I solved this by doing the following:

  1. Go to your Gmail window. On the left there is a red "Gmail" and a triangle on its right. Click on the triangle and select "Contacts". Then a new window/tab should pop up.
  2. In the new tab, find yourself on the contact list and click.
  3. click on the profile picture icon to set profile photo.
  4. choose the picture you want or upload a new one. Save.
  5. Go back to Gmail and try sending an email. Now your profile picture should be updated

+6. I had to click the "go to old version" on the left hand side. My old contact was not showing in the new gmail inbox contacts. When I went to the old version, I found three old contacts for myself. I deleted these and this resolved the issue.

  • Lol, this actually worked. Basically under each Gmail account (I have more than one). I had to go to the contact with my email address in it, and then do the "Remove Photo" then it switched to the Google Account image. – Wasted_Coder Aug 19 '19 at 17:28
0

Conversely, you can just update your own avatar image from the contact list without deleting your own email address from the contacts list!

0

The only thing that worked for me was to go to https://get.google.com/albumarchive and delete the photos from there.

Once you delete the photos make sure you log out of your account, delete all the google cookies and then log back in. Try another browser if the old profile photo is still there.

You can also try https://aboutme.google.com/ but apparently it does not allow deleting existing profile photos.

Related links:

-2

I searched and searched for an answer to this very question. Unfortunately, I always found the same answer, and my avatar never changed. But I finally found a way to change it. How does one do this? After changing the avatar in the Settings, remember to clear the browser cache! It's a step so simple and obvious that no one even bothers to mention it.

You can only guess how silly I felt after doing this... especially since my responsibilities at work place me in the center of the software development team.

  • 1
    The OP says he has already cleared the browser cache. – Vidar S. Ramdal Mar 5 '14 at 8:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.