I have my own domain that is hosted by 1and1, and my public email address [email protected] is setup to forward to my Gmail email address. I have Gmail setup to use my public address as the "from address".

I can't use Google Apps because I can't have the MX record pointing to Google as:

  • Some of the email addresses are forwarded to another email system.
  • I have a long-standing Gmail account that I am not willing to lose all the archived emails from (and their labelling.)

How can I:

  • Get Gmail to use my own email address in the "sender" header?
  • Get "Sender Id" working correctly so emails I send don't look like spam?
  • Get "Domain Key" working correctly so emails I send don't look like spam?

1 Answer 1


When you set up Gmail to send mail as your other account, there are two choices:

  • Use Gmail's SMTP server
  • Use another SMTP server

If you choose the latter option, it should use your real mail server to send the email message. This should produce the same exact email message as if you logged in to your other email host and sent a message from there.

For information on how to use a different SMTP server, see Google's help document. Find the part that says If you choose to send mail through another domain's SMTP servers.

Google says that this is one of the reasons to use your own SMTP server:

Your Gmail address will still be included in your email header's sender field, to help prevent your mail from being marked as spam. Most email clients don't display the sender field, though some versions of Microsoft Outlook may display "From [email protected] on behalf of [email protected]." For this reason, if you don't want 'on behalf of' to appear in any of your messages, we recommend using the SMTP servers of your other email provider.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.