4

Ever since Google implemented high-resolution contact pictures (I believe), whenever I upload a new picture for one of my contacts (using Gmail's web interface), it appears as a new, separate, private album on my Picasaweb account, having the (upload?) date as album caption.

So now when I open Picasaweb's interface in my browser, I see all these faces appearing, instead of my beautiful photo album covers. It's a bit of a mess, really. Guess I should be thankful the albums are private by default ! enter image description here

How can I prevent/undo this ? I haven't found any option in Picasaweb's, Gmail's, Google+'s or even Big G's dedicated contacts.google.com's settings page.

This also roughly coincides with my switch from an Android phone to a Windows Phone 8 device. Could it possibly be caused by a synching issue there ? Only app related to Picasa/Google Photos is the PhotoCasa app, but that doesn't have any option, nor anything else that could suspect it to be the culprit.

BTW: the 'profile picture albums' do not appear on Google+ automatic uploads.

  • Same with my android phone... So it's not caused by your phone. – gagarine Mar 9 '13 at 22:49
1

Maybe it wasn't clear in my question, but the contact pic albums only appear in my 'private feed' of albums.

Considering the above, and the lack of any answer to my question, I will assume that those albums appear here because of the fact that Google uses your unified 'Google Storage' for the high-res contact images, and they are exposed to the Picasaweb interface, much like the automatically uploaded smartphone pictures in Google+ Photos (and Picasaweb).

Feel free to correct this statement if you know of any details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.