I use Google Docs (Drive) to share PDFs with my customers.

For each PDF, I've selected "prevent users from downloading" for IP reasons.

When users try to print the document they get an error 404 page. I've tried this myself on all "modern" browsers and the same occurs.

I don't get it. Google displays a printer icon plus it makes the option available in the file menu, but on all occasions printing results in an error 404 page appearing.

I've tried Google's product forums and Twitter to absolutely no avail.

Any ideas?

1 Answer 1


Google probably implemented it this way because it is impossible to print the document without having the browser downloading it to the user's computer first.

What I can see, though, is that there's no print icon if I've checked the "prevent users from downloading" option.

Here are two files I uploaded:

  • printable.pdf - users can download, and there is a print icon
  • unprintable.pdf - users are prevented from downloading, there's no print icon

Do you get the same results with these files? If you see the print icon on files which are blocked from downloading, it seems like a bug.

Also note that there will still be a print option in the browser's File menu. There's no way a web app can disable that.

  • I see the print icon on both those files, but get a 404 when I click the print icon on the "unprintable.pdf".
    – MrWhite
    Feb 25, 2013 at 19:39
  • 1
    There seems to be a difference depending on wether you're login to your Google account or not. If I open unprintable.pdf in an Incognito window (in Chrome), I see no print button. If I'm logged into any account (not necessarily the one that created the file), I see a print button, and get a 404 when clicking it. Does seem like a bug - the print button should not have been displayed. Feb 25, 2013 at 20:15
  • Yep a bug: It has recently been reported here: productforums.google.com/forum/#!topic/docs/2E9tLNWdhAw - and a Google person is participating in that thread. Feb 25, 2013 at 20:17
  • Thanks guys. At least I'm not going totally mad. Clearly looks like a bug.
    – jsaipe
    Feb 25, 2013 at 21:23
  • Seems the bug has been acknowledged: I have escalated it and the product team will surely fix this soon. productforums.google.com/d/msg/docs/2E9tLNWdhAw/6EMba3d4RpYJ Feb 28, 2013 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.