I just worked hard creating a Google Calendar and invited a few Google users. They got the invitation and opened it, but for them it shows all the events in blue—no event colours as I edited it.

Why is that? And how can I get them to see the same I do?


I think you are hoping that your colored calendar events are visible to other users? If so, here's what's happening:


Color coding is private to you and anybody who can edit your calendar. People with whom you share your calendar will not be able to see the colors you’ve assigned to events unless you give them “Makes changes and manage sharing” rights to your calendar.


By default, the "public viewing color" is what ever you have designated as your default within your calendar (via the drop down menu, per calendar)

  • Interestingly, this sometimes already works with "Make changes to events" and sometimes, it's neccessary to set it to "Make changes and manage sharing". But playing around with these two settings fixed the issue for me. – brimborium Jun 13 '19 at 9:45
  • This is disappointing. I have a calendar that I have set to public, and I have set it to "See all event details", but apparently color is not an event detail. – Michael Dec 2 '19 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.