I can't seem to figure it out. I thought Google Docs supported all the doc file extensions... Was I wrong?

In any case, how can I convert it to an extension Google Docs support? Without downloading Microsoft Office 2011.

I've found guides online, but they're all for .XLSX and others, also some for .XLXS but none of them work.

  • Weird, I can't even try saving a .xlxs format in Excel 2010, though I can do so for .xlsx. Is there even such an extension of .xlxs, or is it just for Office 2007?
    – Hydra
    Mar 15, 2013 at 3:15
  • @Hydra I'm definitely sure it's .xlxs, perhaps it only comes with Office 2011? I have a Mac...
    – greduan
    Mar 15, 2013 at 13:41

2 Answers 2


I figured out the problem. Thanks @Dorje for your help, gave me a hint. :)

The problem was with the file's file extension, it ended with .xlxs, that was the name Microsoft Office 2011 gave it, so I thought it was correct.

I renamed the file with a .xlsx extension, and when I uploaded it again it was correctly encoded in the new language.

For anybody with this problem in the future, the problem is the file extension. :)

  • .xlxs is a rather rare file extension (since I can't really find it anywhere), but changing it to .xlsx should not be too much of a problem.
    – Hydra
    Mar 18, 2013 at 2:31

So, it looks like you want to upload an Excel document that has an .XLXS file extension. If that's it, go to drive.google.com, choose the upload icon a picture of the steps to choose upload, find the file you want to upload, and choose upload.

If in addition to this you want to edit the file, you need to click on the check box next to the file you want to edit in Google Drive, choose "More" in the menu, choose open with a picture of the open with dropdown, and choose Google Sheets. This will make it editable in Google Sheets.

Weird huh? I hope this helps.

  • 1
    It helps but it doesn't work. Google Sheets doesn't appear as an option... Only Google Drive Viewer... I've tried in several other ways but it doesn't let me edit it.
    – greduan
    Mar 15, 2013 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.