4

I am trying to create an annotation in a YouTube video to link to a blog post. The URL I am trying to link to is http://laggacy.wordpress.com/2013/03/15/slender-the-arrival-beta-preview-extra-content/ but when I try to enter that into the field I get an error saying Please enter a valid URL.

I have verified my channel, I am part of YouTube's (new) partnership program, I have associated the website and I have enabled my account for external annotations. Why won't this work? Is it because I'm hosting the blog on a subdomain?

10 Answers 10

4

It is not clearly mentioned on the YouTube help pages, but external links to a different subdomain than your associated website are not accepted.

For example, if you add and verify www.example.org as your associated website, you can create an annotation link to www.example.org/your/content but not to subdomain.example.org – YouTube will just ask you to enter a valid URL.

1

Personally I have never tried adding links in annotations to my YouTube videos but I just looked up the rules on their help/tips page and it appears that you can only add links to "content" [other videos/same video/channel pages/search results] or "calls to action" [subscribe/compose message/video response]. This essentially means your links in annotations can only be YouTube related and not external.

0

Why not shorten the link with bit.ly. This would produce a valid URL.

http://laggacy.wordpress.com/2013/03/15/slender-the-arrival-beta-preview-extra-content/

becomes

http://bit.ly/12VqTti

  • 4
    Shortening a URL is against the regulations of the external website annotation – user35263 Apr 5 '13 at 23:42
  • It wouldn't make a difference by shortening the link, as it is still an external domain, bit.ly. I don't think the URL being a Wordpress subdomain is the source of the problem, but rather, it not being somehow associated by Google correctly. Regardless, @davblayn is correct. – Ellie Kesselman Apr 6 '13 at 23:30
  • davblayn Do you have a link to the regulations of the external website annotation? My searches have not found these terms and conditions you mentioned. – designerWhoCodes Apr 9 '13 at 16:02
0

I had this same issue, and found a simple solution: For me anyway, the problem was caused by using Firefox. When I used Internet Explorer, all was ok. Hope this works for you.

0

You can put your own web site URL in, but it has to be validated first. YouTube validation will give you a piece of code that you have to upload to your site to verify that you own it. After that process is completed, you can use the URL in you "Associated Website" notation.

  • Could you explain how to do this, or link to a page from YouTube explaining how? – Andrew Lott Jan 1 '14 at 20:54
0

YouTube wouldn't let me post the link to my website which was already associated. I removed the association and associated again to the same website and it worked.

0

Solution:

Create a subDIRECTORY (website.com/directory) that has an index file (or htaccess file) that redirects to the subDOMAIN (subdomain.website.com)... then link YouTube to the subDIRECTORY (website.com/directory).

-1

I had the same problem, but in my case it was solved by leaving out the www from the address when I verified it. Crazy how temperamental it is in response to all these little details.

-1

It could be that the URL you are putting against the video is not the verified URL for the channel you are working in. Do you have more than one channel?

-1

Have you clicked enable on the blue bar across the top of your video manager page?

  • 1
    Your answer would be better if it was not phrased as a question. Please rewrite it so that it looks like an answer to the original question. – Vidar S. Ramdal Mar 9 '15 at 14:49

protected by codingbadger Mar 9 '15 at 15:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?