3

I'm having a problem with Google trends: it keeps coming up in what it looks like Chinese.

I tried to eliminate several potential causes:

  1. Signed out of my Google account -> still in Chinese.
  2. Signed in with a different account -> still in Chinese.
  3. Deleted all of the cookies -> still in Chinese.
  4. Checked that my IP is not geolocated in China -> it's geolocated in the US.

I'm using Firefox 19.0.2, but when I try with Chrome it works just fine and Google Trends shows up in English. Any ideas what might be happening and/or how to fix it?

Here is what it looks like:

enter image description here

  • The fact that it works fine with Chrome points to a misapplied setting in Firefox. – ale Mar 29 '13 at 16:09
  • Yah, I'm not sure what could have possibly caused it... – Kiril Mar 29 '13 at 16:46
  • @Lirik: What OS are you using? As it might be the way languages are configured in your Internet Options (on Windows). – Dominic Zukiewicz Apr 3 '13 at 9:27
  • @Lirik Have you tried using another browser, clearing cookies or clearing the cache and retrying? – Hydra Apr 3 '13 at 10:35
  • @DominicZukiewicz I'm using Windows 7 and I only had English (US) configured for the browser. – Kiril Apr 3 '13 at 12:08
4

try clicking this link, it may fix your problem:

http://www.google.com/trends/?hl=en

What happens is this: Google saves a state of your "current language" in their servers. They probably use this to customize ads for you.
This "?hl=en" parameter tells Google you prefer a different language (English in this example). It works across all their services.

  • 1
    point taken - improved answer – Amir Uval Apr 4 '13 at 19:29
  • @uval that fixed it! Big 10x! – Kiril Apr 4 '13 at 19:54
  • 1
    Currently it brokes after page refresh – john c. j. Jun 19 '18 at 19:24
1

in 2019,using the "http://www.google.com/trends/?hl=en" can direct to english language on google trends,but when you type some words to search it return chinese again.

so there is another solution:

  1. visit google account settings:https://myaccount.google.com
  2. click Data & personalization-General preferences for the web-language,choose english and save
  3. refresh google trends and search,then it works in english

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.