10

In my Google Calendar, I sometimes find spam events that I never created.

In the screenshot below, you can see that they even managed to put my email address in the "Created by" field.

They are always in the past.

I could not find much information about this problem. This Google support tip tells me to click "Report spam", but there is no such link.

I could simply remove the event, but is there a more long-term solution?

I am using an up-to-date Firefox, on updated Ubuntu Linux, and check Google's "Activity on this account" often, so I think I can rule out the possibility of account hijacking.

screen shot


The spam events appear in my main calendar (I mean: the first one on the list, the one which does not have an "unsubscribe" link).
The sharing settings for this calendar are as seen below:

enter image description here

  • Is this on your main calendar, or a separate calendar you've created? – ale Apr 5 '13 at 13:12
  • @AlEverett: The spam events appear in my main calendar, sorry for forgetting to mention this. I added a screenshot of the sharing settings. – nic Apr 8 '13 at 0:59
11

I have found the answer here.

Resolution:

  • In Calendar: Click the gear, select "Settings",
  • Find the "Automatically add invitations to my calendar" section,
  • Set its value to "No, only show invitations to which I have responded".

enter image description here

  • D'oh! Of course! Why didn't I think of that? (I've removed my incorrect guesses.) – ale Apr 23 '13 at 12:26
  • Update 7 weeks later: I got such a spam event again! It appears that the setting got switched back to Yes, even though I hadn't touched it or even opened the settings page ever since. – nic Jun 11 '13 at 9:15
  • Apparently, this is a well-known exploit and may not be fixed any time soon. Ars Technica: How Google Calendar can be a spammer’s best friend – ale Jan 28 '14 at 19:00
  • 1
    I wish they had an actually useful setting, such as "Only add invitations received from people I've emailed" or "Only add invitations from my contacts" – Ben Voigt Sep 13 '14 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.