3

I haven't had any luck getting an answer from Google on this, and I couldn't find this on their "tour," but the new compose and reply screens don't appear to have an area where you can set the "from" address if you have other hosts set up in your account.

This is a problem for me, as I use Gmail for multiple e-mail addresses that all forward to the same place.

For now I've set it to go back to the "old" compose screen, but once I'm forced to use the new one I'm not sure how (or if) it can be done.

migrated from superuser.com Apr 8 '13 at 14:05

This question came from our site for computer enthusiasts and power users.

5

Click on the dropdown on the From field, you can switch between sending from email address

enter image description here

  • Apparently I was bugged, by disabling and then re-enabling it, that popped up for me. Before it wasn't an option. According to some preliminary research, it looks like it just hadn't loaded in my other accounts. – NateDSaint Apr 8 '13 at 14:16
  • I had the same problem. My other account was enabled though, but the From field was not there as seen in the above picture. After going back to the old compose and turning back 2 months later, it was there. No idea why now. Anyway, great, bc otherwise new compose would have been useless for me. – e-motiv May 8 '13 at 11:32
1

I just discovered this today: The From field is hidden until you click the To field.

0

Apparently this is only working when you replying to an email and not when composing a new message

https://support.google.com/mail/answer/22377?hl=en&ctx=mail

The iink shows how you can switch between FROM account when replying by clicking on an empty field next to a recipient

0

I just ran into this problem and found the answer. I am a GMail user with multiple aliases. They won't appear in the compose email window until they are added to your gmail account. This sounds repetitive, but follow me down the rabbit hole.

Click on the gear to drop down the setting menu and click on "settings"

At the top of the screen click on "Accounts"

Under the heading, "Send mail as:" Click on "Add another email you own."

In the window that pops up, give the account a name and enter the email address and click the box that says, "treat as an alias."

Now when you go to compose an email, you'll have the option to choose which email to you want to use.

This is a strange problem that Google Mail isn't speaking to my Google Account.

-1
  • Go to Settings by clicking wrench menu and click settings ,
  • Go to Accounts and imports tab In Send mail as menu
  • click Add another email address you own Add your address in wizard
  • and confirm the email address...

Its done You can choose email id from from field

  • The other accounts were already imported, the problem was the from wasn't showing up. It also still doesn't show up if you are replying to a message, but you can set your settings there to set it to the addressee of the original mail instead of using your default now, so that solves the problem somewhat. – NateDSaint Apr 9 '13 at 17:54
  • Vignesh, it seems like the only way to change it for a reply is to click the little arrow on the left side of the inline Reply box to drop the menu down, then choose "pop out reply". So it's an extra step to pop out the composer. Just ran into this issue myself. – user42522 Jun 22 '13 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.