Since a few months I have problems with gmx.net's XMPP service (note that this is the same company that provides gmx.com, but it's not the same service).

It doesn't update my roster anymore, so if a contact goes on/off in the meantime, I can't see it until I reconnect. Also I get sometimes "Remote server not found" errors when trying to send messages to contacts on jabber.org (offline message seem not to work anymore at all).

I searched for this issue and found a mailing list thread, where Kevin Smith says:

I believe this is another example (there have been many) of an ejabberd server running on an old OS. Ejabberd servers on an old OS seem to not be able to cope with the new certificate installed on jabber.org. Upgrading the OS seems to fix this (without upgrading ejabberd) - the current suspect is an old version of openssl.

Does anyone having no problems with XMPP at gmx.net? Or is this really a global problem on GMX's side? As I have this problem for several months now (worked perfectly fine for several years before), it's hard to believe that GMX doesn't know about and fix it. On the other hand, XMPP is probably not that widely used by their users (I guess most use it for email only).

I tried contacting the support some time ago (other issue related to XMPP), but never got a response. Now I can't find a contact form or email address, only an expensive phone number :/

1 Answer 1


In my recent experience contacting friends who use GMX's xmpp service works pretty unreliable. Only friends with a gmx.net|gmx.com|gmx.de|gmx.at|gmx.ch address can be reached OK. They are routed via xmpp-gmx.gmx.net[]. Friends with a gmx.biz|gmx.info|gmx.name|gmx.org|gmx.eu|gmx.tm|gmx.co.uk|gmx.ie|gmx.fr|gmx.lu|gmx.li|gmx.it|gmx.se|gmx.pt|gmx.es|caramail.com|... address are routed via jabber.gmx.net[] and often appear offline and message delivery fails:

Presence Error: Remote server not found. A remote server or service specified as part or all of the JID of the intended recipient does not exist.

BTW, starttls only works correctly for gmx.net and gmx.de addresses. For other addresses the CN returned is always gmx.net. By default many XMPP clients don't validate certificates, for instance Miranda comes with "Validate SSL certificates" disabled and if you enable it Miranda simply drops the connection. Other clients like Jitsi tell you about the CN mismatch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.