10

We've been struggling for a few weeks with all messages sent via a Google Apps account also appearing in its own inbox (as already read), as well as in the correct "sent" folder/label.

We tested it from different IMAP connections and reviewed all configs without success.

migrated from superuser.com Apr 11 '13 at 20:20

This question came from our site for computer enthusiasts and power users.

  • And what’s the question? – Alex Feb 10 '15 at 22:20
11

Finally figured out via a few comments on forum it had to be filter related. As this is a heavy filtered account it took us a while and the answer was a simple rule to avoid mails from our own domains being classified as spam.

In Gmail filters an action of "never classify as spam" apparently also applies to sent messages and automatically assumes unless you specify another it will put it in the inbox.

So once we removed a rule of type:

Matches: from:(@alsur.es)
Apply: never send to spam

The problem was solved

  • To confirm was @alsur.es the domain you were sending it from ? – sam Mar 18 '14 at 12:58
2

A filter using the Never send to spam option can also lead to sent mail in the inbox. A side effect of Never send to spam is to apply the Inbox tag to messages matching the filter. Filters are also applied when you send a message, so if your sent message matches the filter, it ends up with the Inbox and Sent tags.

This situation only occurs with filters that can match a message being sent, so if you're filtering on to: or from: it probably won't match when you reply to a message because to and from get reversed in the reply. Usually the problem happens with subject or body filters, or if you filter on from: [your domain].

To fix the problem, add a to: [your email] criteria to the filter. Example if you receive email at me@domain.com and myself@domain.com:

Has the words: (to:me@domain.com OR to:myself@domain.com) AND (subject:(Match this subject) OR from:domain.com)

Notice you need parenthesis around the two clauses that are separated by AND:

(to:... OR to:...) AND (subject:... OR from:... OR subject:...)

1

I have also had the problem of a copy of my Gmail sent mail showing up in my Inbox. I put in filters, I checked one Gmail account against another where this was not happening. Today I figured it out. Go to Gmail - Settings - Forwarding POP/IMAP - POP Download. Find the question "when messages are accessed from POP (options). Mine had (keep Gmails copy in Inbox). It is a drop down box so you have options. I used (delete Gmail copy). I am still getting a copy in Sent mail. I hope this helps someone avoid the frustration I have had solving this issue.

  • Something I noticed in one email sent in duplicate from gmail: Email copy was forwarded to my computer but only a few words in first email, more in the next email etc. There were approximately 30 email copies sent of one email. I have now changed settings thanks to Thomas. I have found the drop down box and changed to delete message. Thanks to those who come to give their suggestions. – Marie Seltenrych May 27 '17 at 1:07
0

From my experience, this is due to the use of the "recent:" feature* in Gmail.

Once removed, the duplicate sent emails disappear. If you have two or more computers, this is a useful feature and the only way to deal with it, is to create a filter to archive it. Otherwise just remove it.

* for downloading trough POP3 the same email to more than 1 computer or device.

0

I took care of the problem by fixing the filter I had in a way that declares that only when the mail is for me apply the rule.

So when I send a mail the rule does not apply and the sent mail is automatically archived in the sent mail folder only.

  • Perhaps you could share the exact text of the filter for the benefit of others. – ale Dec 5 '14 at 0:49
0

"Never Send To Spam" is definitely the culprit. See https://productforums.google.com/forum/#!topic/gmail/n52yH-ucY5o I consider this to be a bug in the filter action, since I don't expect it to act on mail that is not spam, and it i

0

None of the advice on this page worked for me. I was receiving a copy in my inbox of every email I sent from some of my Google email accounts. I created a filter that deletes email from the email address of the account, now it's deleted without me seeing it. BTW, changing from POP to IMAP is not an answer to how to keep this from happening in POP accounts.

-1

I had the same problem, where all of my sent mail was in my inbox. Go to Settings, forwarding POP/IMAP, disable POP and use IMAP.

-4

Go to settings > Inbox > Inbox type > Select Priority Inbox.

  • How does this solve the problem? – ale Apr 3 '18 at 21:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.