On the spreadsheet in question there is a column that contains plain numbers in a particular sequence. As an example: 3040513, 3050513, 3060513 etc.

Sometimes when typing in the next sequenced number it will automatically add commas, so the number comes out as 3,050,513. It also does this if I highlight a row of numbers above to use as a "guide" to add numbers automatically to rows below.

I have tried to set the column format as plain text and as no decimals to no avail. Any ideas?


Are you sure Plain Text didn't do the trick? In my spreadsheet, it worked.

  1. Highlight the cells
  2. Click FormatNumberPlain Text

Here's a reference, saying the same thing with more words: Remove Commas.

  • While this works fine for integers, it makes it impossible to restrict the number of decimal places. If you tell the the spreadsheet that a cell is restricted to N decimal places, it becomes a number, and gets commas. – ghoti Jun 28 '13 at 16:30

If setting the column as plain text doesn't work, try changing the format to Automatic.

Click Format → Number → Automatic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.