Today I've got this message, when tried to copy data from my Google Docs spreadsheet:

enter image description here

It says I can't use copy/paste if I don't install the Google Drive app. It seems this message is bound to context menu commands and I'm still able to copy data using clipboard shortcut, though.

I've never seen this message before. Is this their new policy, or I missed something?

UPD Interesting, that I'm getting this message only in one of my accounts; while another says "These actions are unavailable via the Edit menu, but you can still use: Ctrl+C Ctrl+X Ctrl+V"


9 Answers 9


I get this message on Windows (Chrome) when I try to copy using right click -> copy. If I use ctrl+c, it copies without a problem.


The reason for this is that, for a number of security reasons, browsers have limited capability to interact with the operating system's clipboard. If you think about it, this makes sense as the content within a browser window/tab runs as an isolated sandboxed environment to prevent possible malicious interaction with the OS.

As such, alternatives have to be implemented to get around this limitation. One way my shop gets around this is to use an off-screen textarea element as a storage destination for formatted text. However, this also means that Edit->Cut | Copy | Paste and/or Right Click -> Copy do not work as expected in many web apps, including Sheets.

For more reading, USA Today ran an article with a good, low technical expertise required explaination.

  • 1
    This is just not true, because this problem wasn't happening in my another account - in the same browser. It has absolutely nothing to do with the browsers security limitations.
    – user626528
    Oct 5, 2017 at 19:27

The Google Drive web app gets around a security feature on the browser. Without this security feature, a script on any web page you open could grab sensitive data from your clipboard.

When you right-click in Google Drive, the script on that page shows the menu, and when you select "Paste" from that menu it calls another function in the script that attempts to transfer data from the clipboard. There is no way for the browser to determine if this is what the user really wanted to do, because it's all deep in the script on the page.

On the other hand, Control-V works because that key event goes directly to the browser, not the script.

The right way to solve this problem would be for the user to be able to grant clipboard access to trusted pages or domains, but only IE implemented something like this, it it appears to not store this grant.

  • Ctrl-V does not work in Firefox.
    – Pointy
    Jun 14, 2016 at 0:16

I encountered this frustrating message in Chrome yesterday and got around it by simply attempting the same thing from Internet Explorer 10.

IE10 gives you the warning "Do you want to allow this webpage to access your Clipboard?" and if you click Allow Access, it pastes like you'd expect.

For now, I'd much prefer to use a clunky copy/paste process in a clunky browser than be required to install loads of Google binaries on my system.


Google has re-launched the google docs application as part of the google drive, which combines storage of email, photos and docs. Once you install the google drive app for your browser, the documents are editable exactly as they were in google docs. You will be given 15GB of space on Google Drive.


Also, the document shared with you will have to be given the 'editable' permission by the user who created it.

  • So, only the last remark is eligible as an answer? May 14, 2013 at 15:39
  • 1
    I already have editable permission. And the first part of this answer sounds for me like Google is trying to enforce users to install Google Drive.
    – user626528
    May 15, 2013 at 3:13

I got around this by pasting the text first into the address bar in a different tab (on Chrome) and then copying it from there and pasting it into docs.

I guess the browsers are now restricting access to the system clipboard as an additional security measure, which seems reasonable.

However, I still don't want to install yet another Google app on yet another machine and increase Googles omnipresence in my life - so I'm glad this workaround is still available.


I ran into this for the first time today. It's now a year after the original post. And I, too, thought they had "suddenly changed it". But I was able to go back and do it successfully after looking for an answer. Same file, same browser. The difference--on a Mac, there's control-C but also command-C. They seem to do the same thing, but apparently one uses the operating system's clipboard, while the other must use some kind of web-enabled clipboard implemented by the page's scripting. There is probably a similar look-alike command for Windows systems.


I had the same problem. I did:

  • install Google Apps
  • sign in Google Apps: go to settings in Google Chrome then at the top sign in.
  • Clean the cache and cookies and then I was able to use the mouse to copy and paste.

Try this, it worked for me:

Go to File → Download As, select Microsoft Word or Open Document (depending on what you have).

Then open the downloaded document on your computer, and copy the text from your word processor.

Not the answer you're looking for? Browse other questions tagged or ask your own question.