I noticed during the last days that Twitter adds a “translation” from Bing Translate to tweets when I expand a tweet in the web interface. This happens even on my own tweets.

screenshot of poor translation example

Is there a way to turn the automatic translations off?

The translations are so bad, they aren’t even funny anymore.

What I have tried already

  • I searched in twitter.com/settings/account for a translation checkbox.
  • Switched the interface language from German to English (I post in both languages). This switches just the languages that get translated; it doesn’t stop the translations.
  • I checked twitter.com/settings/applications for a Bing app or something similar.
  • Searched the Twitter support pages for “Bing”. No useful result.
  • Asked the German and the English Twitter accounts.
  • Sent a message to Twitter via the feedback form.

I might get a feedback from Twitter later. I will update this question then. But for now, I don’t see how to turn it off.

3 Answers 3


As suggested by @Zedinc, I have added the following rule to my user stylesheet:

    display: none !important;

This hides the “translations” completely.

The translations are loaded via an XHR (AJAX) request to


I blocked this URL, but for no obvious reasons my browser (Opera) still loads it. So the performance penalty is still there; I just don’t have to see it anymore.


Unfortunately, there is no way to turn off these translations. The translations are shown when your interface language is different from the language Twitter thinks the tweet is written in (and Bing Translator supports the language pair).

You can always use a Greasemonkey script or similar to hide them, but there aren't any settings to disabling them on Twitter.

  • But will the Greasemonkey script be executed when opening a tweet? Jun 10, 2014 at 21:36
  • You can bind the removal to a click handler for opening a tweet, which should do the trick at least. I'm not an expert with Greasemonkey, though.
    – Zedinc
    Jun 12, 2014 at 11:31

Use AdBlock on Chrome, you won't see it again.

  • 3
    Please explain how to use AdBlock to solve the problem. An answer to a question is supposed to be extensive. The asker isn't supposed to have to search to know how to apply your answer (in general). Mar 25, 2014 at 23:40
  • That would require using Chrome, the most inaccessible browser. The result would be worse for me.
    – fuxia
    Mar 26, 2014 at 2:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.