Facebook now doesn't show me all my friends' updates, just what "it thinks" is my friend. I don't see posts on my timeline from people that I care about. I understand I need to change what appears on "edit options", but all I see is just "hide posts from" not "show posts from everyone". How do I do this?

2 Answers 2


There are a couple of settings you can adjust to change what and the order in which you see content in your news feed. In Facebook's Controlling What You See in News Feed the first method suggested is changing how you sort stories in your news feed (in your case you would probably want "Most Recent" to see stories from all of your friends in order of recency):

Use the Sort menu in the top right of your News Feed to choose which stories you see first. Click Most Recent to see stories in the order they were posted, or click Top Stories to see the most interesting stories at the top of your News Feed. Sort facebook news feed

You can also Filter by friends list (which it sounds like you do not want to do, so make sure this isn't selected) Filter by friend lists

Click one of your lists on the left side of your home page to see stories just from the people on that list. Filter friends list for news feed

As you mentioned you can also hide or unhide stories.

You may want to check to make sure your settings include all stories since some users seem to have only close friends selected by default (see Facebook Changes News Feed Settings, Some Users Only Shown Close Friends by Default) I should note, however, that I wasn't able to find the interface shown below, so these adjustments likely are made in the previously mentioned sidebar where you can select sub-lists of friends

Edit News Feed settings

For the new news feed layout (circa April 2013 according to Mashable's How to See EVERYTHING in Your Facebook News Feed) the interface looks like this:

enter image description here

  • 1
    That didn't help me... I don't want just to rearange stories, I want more stories to appear! And the bottom panel ("edit your news feed") isn't showing at me aither... I don't have show post from...
    – Ran
    Jun 30, 2013 at 14:20
  • @Ran right- so the way it works on FB by default is that certain posts (and not others) appear depending on how they are sorted, you can read more about it in Mashable's How to See EVERYTHING in Your Facebook News Feed Jun 30, 2013 at 15:28
  • Although they describe exactly what I want - I don't have the arrow they are talking about... I hope "Most Recesent" will show me what I want...
    – Ran
    Jun 30, 2013 at 15:46

Go to "Home Page" > Scroll down left side > "Close Friends"(click) > right side ... "On the List ... see ... Add" > "ADD" those missing from posts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.