8

This is the only checkbox option I have whether I'm posting as the Page or myself:

"Send me a notification on Facebook when people post, like, comment on, or send [your page name] a message."

Is there any way to be able to receive notifications only when you have comments, and not when you also have Likes?

It's frustrating to have to sift through 30 notifications for people that Like your Page just to make sure you can respond promptly to the one comment. It's a huge waste of time when it doesn't have to be.

This is what the options should be IMO:

"Send me a notification on Facebook when people post, comment on, or send [your page name] a message."

"Send me a notification on Facebook when people like [your page name]."

2

You can't turn off like notifications without turning off all notifications for a post. Apparently folks have been complaining about this for years. Even though you can't turn off just likes, there's hope. When you have a lot of notifications, click on the globe icon and they will all be highlighted in blue. Exit out of the notifications by clicking somewhere else on the screen, and then click on the globe again. Only the comment notifications will be highlighted. Found this out by accident this week when I posted a bunch of historic pictures, and hundreds of likes came pouring through. Makes life a lot easier when you know how to handle it, huh?

  • 1
    This may have worked in the past, but doesn't work now. Try the "facebook hide like notifications" I posted in my new answer. – JD Smith Jun 13 '17 at 14:30
1

You can change what you get notifications about by going into your notification settings at: https://www.facebook.com/settings?tab=notifications

Facebook Notifications Settings

From there, you can edit what types of notifications will be sent to your email (ie. Likes, Pokes, Friend Requests, etc.). Unfortunately, your options for configuring "On Facebook" notifications are more limited.

  • 1
    No options for likes alone. – Chloe Nov 9 '16 at 20:14
1

You can turn off Like notifications:

  1. Install and open http://www.fbpurity.com/
  2. Click the CSS link and add the following CSS code:
li[data-gt*=like] {display:none !important;}
  • This only seems to hide likes on posts and such you've made on your personal, not on a a page you administrate. – Punchlinern Oct 19 '15 at 9:49
  • See my answer below for the correct solution. – Brian Smith Jul 13 at 19:33
1

I use the Chrome extension called "Hide 'Like' Notifications" and it works brilliantly. Unfortunately I don't know of a way to hide them on the mobile native apps yet though.

1

To only view comment notifications:

  1. Install and open http://www.fbpurity.com/
  2. Click the CSS link and add the following CSS code:
div[data-gt*=notif_page] li:not([data-gt*=comment]) {display:none !important;}

The above code will only work on this page : https://www.facebook.com/notifications

You can still view all notifications by clicking on the notification bell icon in the menu bar.

New contributor
Brian Smith is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-1

There is a "Facebook like hider" addon in Firefox 60.0.1 that claims to do exactly this, and optionally remove "like" entirely.

-2

I understand your frustration. On Facebook Help Center I have found that :

Notifications help keep you up-to-date on what's going on. While you can't turn off notifications entirely, you can adjust how you're notified and what you're notified about.

To turn off specific types of red alert notifications as you see them:

Click the globe icon

Hover your mouse over the notification you want to stop seeing and click the X that appears

Click Turn off

Read notification are appear in the upper-left corner of the site. When you have a new notification, a red bubble will appear with the number of new notifications you've received. There are separate notifications for friend requests and messages, and the rest of your notifications will appear over the globe icon.

  • 1
    you did not answer the question. – mist Dec 5 '13 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.