27

I live in the UK, and whenever I visit google.com I am redirected to google.co.uk, but I want to see my website's rankings on the US version (I presume the results are different). Is there a way to do this?

1

5 Answers 5

23

Editor's note: Since the finals of 2017, Google has no longer used country domains to serve content for several services. Ref. Making search results more local and relevant.

To make this crystal clear, the question is obsolete as well http://www.google.com/ncr.


Try http://www.google.com/ncr

This is only one of several ways to do this according to Google:

  • Click the Google.com link on any other domain.
  • Choose a Google domain manually by visiting the Language Tools page (the section with the flags).
  • Bookmark http://www.google.com/ncr. This is an alternative web address for Google.com that always takes you to Google.com without redirecting you.
2
  • 1
    This link is redirected to https://www.google.com/?gws_rd=ssl and it seems that this does not work.
    – Blaszard
    Commented Apr 7, 2016 at 17:03
  • 1
    The quoted help article no longer mentions the /ncr URL. This makes this answer obsolete. Commented Oct 23, 2023 at 19:25
4

Change your bookmarks, homepage etc to http://www.google.com/ncr This will ensure that it ignores the IP country detection. Ensure you delete all cookies etc first.

This should display everything in English.

Source Article

EDIT

What you can do is create a custom search within Chrome:

  • Go to "Options"
  • In the "Default Search" click "Manage"
  • Click "Add"
  • Enter the following details:
    • Name = GoogleCustomised
    • Keyword = google.com
    • URL = http://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}sourceid=chrome&ie={inputEncoding}&q=%s
  • Click OK
  • Then click GoogleCustomised and click "Make Default"

This should ensure that Google Chrome always uses www.google.com as the default search site. Which is in English.

Hope this helps

1
3

The only option that worked for me was appending pws=0&gl=us&gws_rd=cr to the URL. I chose to make that my default search engine in Chrome which is one of the three approaches shown below.

  1. Direct URL and Search Box
  2. Search by customizing URL
  3. Add a browser search engine (what I chose).

1. Direct URL

Navigate to the Google Search page and use the search box as per normal:
https://www.google.com/webhp?pws=0&gl=us&gws_rd=cr

2. Search by custom URL

Replace [mySearch] below with your search string:

https://www.google.com/search?q=[mySearch]&pws=0&gl=us&gws_rd=cr

For example, the search "web apps work" would use the URL:

https://www.google.com/search?q=web+apps+that+work&pws=0&gl=us&gws_rd=cr

3. Add Search Engine to Chrome

Steps 1-3 can be skipped by navigating to chrome://settings/searchEngines

  1. Open Chrome enter image description here
  2. At the top right, click More More icon and then Settings.
  3. Click Search engine then Manage search engines and site search.
  4. To the right of "Site search," click Add
  5. Populate the "Add search engine" dialog fields and then click Save:
    1. Search engine: eg. Google USA
      A title for you to differentiate the search engine from others.
    2. Shortcut eg. gu
      Provides a way to specify the search engine in the address bar.
    3. URL with %s in place of query
      https://www.google.com/search?q=%s&pws=0&gl=us&gws_rd=cr


       
  6. The search engine will now be listed under Site search
  7. You can use the new Google USA search engine by:
    • Preceding your address bar search string by guSpace

       
    • You can set it to be Chrome's default search engine from the Site search list by clicking More More icon then Make default

       
0

If you just want to permanently use google.com (or any other fixed URL) as the search engine, above two methods probably is not what you are looking for. /ncr and adding another search engine both breaks the default realtime search functionality. Try this,

  1. Close all the Chrome/chromium browsers,
  2. go to User Data folder

    • Windows: users\username\appdata\local\chromium\User Data (or similar - please edit if this is wrong)
    • Linux: ~/.config/chromium/Default
  3. open the file named LocalState (windows) or Preferences in vim/notepad, and change,

    • last_known_google_url and
    • last_prompted_google_url to whatever the baseURL you want. Ex. "https://www.google.com/"
  4. Save.

For more info look at this old bug report.

1
  • 2
    Please note: "above two methods" really has no context here, since answers can be sorted in a number of ways. It's very possible that your answer is currently "above" the answers to which you are referring.
    – ale
    Commented Jan 31, 2014 at 13:17
-1

This one works perfectly for me:

https://www.google.com/webhp?hl=en

Not the answer you're looking for? Browse other questions tagged or ask your own question.