7

It has annoyed me for ages that when I'm reading the slashdot main page, from time to time new stories are automatically loaded, pushing down the one I'm reading and making me lose my place. Recently it's gotten worse - instead of using AJAX to update the display it actually loads a whole new page, http://slashdot.org/?source=autorefresh.

Is there any setting or preference on the site to turn off this annoyance and put me back in control? (I'd prefer not to resort to installing a browser extension or using a modifying http proxy)

4

This annoyed me too. I disabled it using Adblock Plus on Firefox.

Assuming you have those installed, it is very simple and allows the rest of the site to function normally. Go to Tools -> AdBlock Plus -> Filter-preferences.

This brings up the filter preferences window. Here, go to Custom filters -> Add filter -> http://a.fsdn.com/sd/autorefresh-query.js

And that's it.

Technical details:

The relevant code is here:

<script src="//a.fsdn.com/sd/autorefresh-query.js?release_20140319"></script>
<script>
    // Set Timeout to reload the page and trigger the manageQueryStringParam function
    setTimeout(function(){
        window.location = manageQueryStringParam('source', 'autorefresh');
    }, 1200000); 
</script>

The AdBlock rule blocks loading of the script autorefresh-query.js, which simply defines the function manageQueryStringParam(). This in turn mean setTimeout() won't work and the page won't reload.

| improve this answer | |
  • Thank a lot my friend, your answer should be accepted by the OP. This works like a charm even with news websites in my country (e.g. repubblica.it), which is where I was trying to block autorefresh. – Jeffrey Lebowski Dec 29 '18 at 11:32
3
+25

For the time that I was checking, the page did not refresh. An auto-refresh can be implemented by a developer with JavaScript or through a META tag in HTML.

The Slashdot HTML source code has an implementation of META tag refresh but that line was commented when I saw it. There was also a script. Disable JavaScript in your browser to prevent auto-refresh.

A simple way to disable JS is via the browser's Developer Tools. Use the F12 keyboard shortcut to invoke Developer Tools. In IE Developer Tools, choose the Disable option from the menu and select Script. If you're using Chrome, click the gear icon in the lower-right corner after you've opened Dev Tools, then check Disable Javascript from the General tab. In Firefox, go to Tools > Options > Content and then uncheck the Enable JavaScript option. The NoScript Firefox extension can disable JavaScript for specific domains that you specify.

To disable automatic refresh/redirect enforced through a META tag in your browser, follow this steps:

If you're using IE: go to Tools > Internet options > Security tab > Custom Level button > Miscellaneous category > set "Allow META REFRESH" to Disable.

If you're using Firefox go to Tools > Options.. and in the Advanced section's General tab, check the "Warn me when web sites try to redirect or reload the page" checkbox in the Accessibility panel.

| improve this answer | |
  • +1. I could disable JS but unfortunately there is some good functionality on the site that uses it. – Hugh Allen Aug 8 '13 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.