6

I have two Google mail accounts: my main account ([email protected]) and a Google Apps account ([email protected]). I would like to use my primary gmail.com address to sign in and receive all mail, but still be able to send mail from an alias of my Google Apps account ([email protected] as opposed to myself@g.mydomain.com).

Gmail provides these settings:

If I choose "Send through Gmail", I can send from [email protected], but recipients see "sent by [email protected] on behalf of [email protected]".

If I choose "Send through mydomain.com SMTP servers", then I'm forced to use the following SMTP settings:

This removes the "on behalf of" header, but now my emails are sent from [email protected] rather than my alias [email protected].

Is there any way to use the alias, but avoid "on behalf of"?

2 Answers 2

2

I found that the only solution was to create another user, for which the primary email uses the alias domain.

In your case, connect to the admin console for g.mydomain.com.

  • First, remove the email alias you say you have set up for your first account.

  • Create a new user with the same name as the first account, and for its primary email address you should be able to choose @mydomain.com.

  • Log in with this new account (the username should be [email protected]), set your password and don't forget to enable mail forwarding.

  • Finally, set the settings of your Gmail account ([email protected]) that you mentioned to :

Job done.

1
  • Thats working. good idea. Commented Sep 15, 2014 at 8:10
2

To make this work, the aliased email address ([email protected]) needs to be configured as a "Send mail as" address in both your regular Gmail account ([email protected]) and your Google Apps account ([email protected]).

When you send an email from your Google Apps email alias while being logged in to your regular Gmail account, the following happens:

  1. Google authenticates you at smtp.google.com with your domain credentials.
  2. Then it tries to send the email from the email alias.
  3. The Google Apps domain account does not know or care that you have the alias configured in your regular Gmail account. If it does not see the alias in its own configuration as well, it will always use the default domain name instead.
2
  • 1
    This should be the accepted answer. Sending from vanilla Gmail through my G Suite domain, my primary G Suite email address insisted on appearing in the headers of outbound messages until I added the custom From address in the G Suite account as well.
    – dgw
    Commented Jul 20, 2017 at 4:49
  • A lot of searching and I totally agree. This should be the accepted answer. Establishing the Send As setup for the alias in BOTH your personal gmail and your G Suite gmail accounts is required.
    – Craig
    Commented Sep 16, 2020 at 4:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.