For the past couple of months, thousands of strange people have been appearing in my Google Hangout when I look for a contact to chat with.

How can I disable that and just leave the people I have in my contact book?

  • 1
    Are these people in your "Other Contacts"? If so, then they're technically one of your contacts. You would probably want to clear that out and fix the setting for "Create contacts for auto-complete": Stop Gmail from automatically creating contacts
    – ale
    Aug 26, 2013 at 15:44
  • 1
    No, the vast majority of the contacts are NOT in the "others" category.
    – Gabriel
    Aug 26, 2013 at 20:50
  • Are they in your G+ Circles?
    – ale
    Aug 26, 2013 at 20:51
  • No.............................
    – Gabriel
    Sep 8, 2013 at 18:42
  • 1
    +1 These "strangers" are Google+ suggestions, and they're still a super annoying problem today for the Chrome extension and Android app (maybe all variations of Hangouts). I've accidentally texted strangers who have the exact same name as my contacts. You'd think the app would be smart enough to prioritize my own contacts.
    – tony19
    Dec 24, 2014 at 4:00

1 Answer 1


The contact search in Hangouts shows first the most recent conversations then other contacts in the Google+ directory. This can not be disabled.

Instead typing the name, you could type the email address of your contact or start a Hangout from

  • The pop-up contact card in Gmail
  • The contact record in Google Contacts
  • The Google+ user profile
  • A Hangout button

Start a Hangout - Hangouts Help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.