4

I liked formatting my e-mails in MS Word and then copy and paste them into Gmail. I did it, among other things, because I could control line spacing and text alignment (I prefer it justified). Gmail used to preserve the formatting, but now it doesn't. Is there a solution?

3

I have spent 2 hours bashing my head against this issue. Finally though I've stumbled on a solution of sorts.

  1. Convert your message to plain text.
  2. Paste the text from MS word.
  3. Convert the message to rich text.
  4. Reinsert features such as bold, underline, italics, and font/size differences.

It's the best I've been able to do so far, but it saves a lot of time and produces a reasonable looking layout.

2

After pasting the formatted content from MS Word then select the pasted content and click on "quote" icon (shortcut Ctrl+Shift+9) from the formatting options above the send button as shown in the image below(highlighted text selected and 'quote' icon) would resolve the issue with a little side-effect of having a gray line to the left of the text indicating it is quoted text. Example to retain text formatted in another application after paste to Gmail

1

I don't know if this will fix the problem in your case, but it worked for me.

In our office, people use a Word template to generate a standard email format, (small table with colored background cells) and then it is pasted in Gmail. It was working fine for everyone, but suddenly, it stopped working for one person. The pasted template appeared as simple text, losing background colors, etc...

When you compose an email in Gmail, in the lower right corner, you have a small drop down arrow for "More options". Make sure that "Plain Text Mode" is UNCHECKED. That took care of the problem for that one person.

1

There's actually a simple way to do this. Most of the time the formatting gets erased when you paste into an existing email thread where you are replying. To fix this, click the ... (ellipsis icon) at the bottom of the email and it should expand the email to show the historical email thread. Now when you paste rich media content, it should post correctly.

1

Gmail still preserves rich text formatting (For example from VS Code) but doesn't like MS Word.

One solution is to copy from Google Docs (either format your email there, or open an MS Word doc in Google Docs).

Yes, formatting is still weird in 2019.

-1

You can use Shift + Option + Command + V to paste without formatting (or with whatever format the pasted text is placed into). ...

  • 2
    Question is about how paste with formatting – Kos Jun 28 '18 at 10:35
-3

Create a single cell table in WORD, insert your WORD text, remove the table's border, copy table and paste into gmail - everything conveys!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.