I enabled two factor authentication with a German number. And since then I'm locked out of my account: verification SMS never arrive

After setting up two factor authentication, I made a quick test, and it didn't work. As I still had the settings page open, I created the screen shot below (phone number edited out). Then I closed that page and hoped for the best. Now I'm locked out for more than a week, and no reply from Twitter customer support.

I then read about short and long codes. In certain countries, one can send SMS to a short code, e.g. 40404, and the message get's posted to one's timeline. Also one can receive tweets to the phone by SMS. In Germany, a short code is not available, only a long code, +491724403473. Here, receiving tweets by SMS from Twitter does not work. That makes me to wonder:

Could it be that Twitter does not send verification SMS in countries with long codes? Could that be the reason why I'm locked out?

By the way, using the long code, I can still post to my timeline, although there were issues in setting that up by SMS, and my password got posted.

My security settings


Twitter in the end answered my original support request, which I sent on 2013-09-25 CEST, i.e. prior to posting this question on Stack Exchange.

Their reply:

Thank you for contacting us about login verification!

It looks like you are using a one-way long code or an unsupported carrier to add your phone to Twitter. By one-way we mean you can post Tweets to Twitter, however you will not receive anything from us (read more about it here - https://support.twitter.com/articles/87284-tweeting-with-an-unsupported-carrier). This means that you are unable to receive login verification text messages from Twitter at this time.

Since I have confirmed you as the owner of this account, I have updated your settings to disable SMS login verification. You should now be able to log in to your account as before.

Please note that Twitter for iOS or Android users should still be able to enroll in login verification from within the Twitter app. You can read more about this feature here: https://support.twitter.com/articles/20170388-using-login-verification#login-verification-for-ios-android

My request (phone number and URL edited out):

My request

  • looks more like your operator is blocking the SMS Commented Oct 4, 2013 at 19:10
  • @Sathya I just called Telekom customer service: They said that everything is in status Go, meaning that no SMS get blocked.
    – feklee
    Commented Oct 4, 2013 at 19:31

1 Answer 1


It is indeed true that Twitter can't send SMS in countries with a long code. Looks like there's an oversight in this system so that it's allowing SMS verification to be used even though it should require confirmation via incoming SMS.

Twitter provides instructions at https://support.twitter.com/articles/20170409, but unfortunately those aren't of much use. I recommend you contact Twitter support via https://support.twitter.com/forms/sms and tell them about your case. They should be able to remove SMS verification for you. Please do read the first automatic reply carefully, as they sometimes require you to reply to it for the case to actually be opened for examination.

  • What I just sent: "Could you please disable SMS verification for my account? Rationale: Since more than ten days, I am locked out of my account. Back then, I enabled SMS verification, but verification SMS never arrive. Possibly, SMS verification does not work in countries with Twitter long code." By the way, my earlier support request I did confirm by email - still no reply.
    – feklee
    Commented Oct 5, 2013 at 12:19
  • Sometimes responses from support can unfortunately take quite a bit of time. The good thing is that you can post tweets to your account via SMS, which helps verify your identity if need be. If you don't have an active login anywhere, support is the only way you can regain access to your account.
    – Zedinc
    Commented Oct 5, 2013 at 17:02
  • Thanks for your suggestions, although in the end they replied to the request that I sent prior to posting my question on Stack Exchange.
    – feklee
    Commented Oct 12, 2013 at 7:20
  • Good to hear you eventually got an answer. Hope they were able to help you with your issue.
    – Zedinc
    Commented Oct 13, 2013 at 19:34
  • The problem is solved. For details see my question.
    – feklee
    Commented Oct 13, 2013 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.