11

I have a fair internet connection speed and every time I play a video from YouTube it defaults to 144p although my connection could support 360p without buffering. I have to manually switch to 360p each time I play a new video. I use Iceweasel on Debian.

Is there any known workaround to solve this problem, like changing some browser configurations? Any suggestions will be appreciated.

PS: I would like to set the quality static, so that YouTube may not switch qualities while I watch videos, preferably 360p.

migrated from superuser.com Oct 4 '13 at 19:04

This question came from our site for computer enthusiasts and power users.

6

There is a userscript, YouTube Auto Buffer & Auto HD, for the Firefox/Iceweasel extension Greasemonkey that (among other things) allows you to override YouTube's default quality setting.

  • that solves the problem – Ashlie Sep 29 '13 at 17:14
  • It has "big" dependencies but I see no problem, gpl and many ppl on it. And it does a lot more indeed! I edited the script to set the default manually to "tiny" to grant today's quota wouldnt be lost to 1080p. A popup (from that script) shows to select it but until you can do that, it would already have buffered on 1080p. It is geared towards what most ppl want/needs and that is good, I wont suggest changing the default to 144p :). – Aquarius Power Oct 29 '18 at 19:50
3

If you're using Firefox, this add on is the Occam's Razor of solutions.

YouTube High Definition

3

This userscript seems to do exactly what the OP wants to achieve: It sets the video quality to 360p (easily changeable from the script source code).

  • easy to read and looks simple, I changed to 144p, but didnt kick in fast enough and the download started at 360p and soon 480p for about 5s eating 2MB of my 100MB quota, I will try more see what happens. – Aquarius Power Oct 29 '18 at 19:29
2

Under your username on the top-right, there will be an option called YouTube settings. On the YouTube settings, you can specify your Playback preferences. Make sure the "best quality for my connection" radio box is selected.

If your connection is as sufficient as you say it is, it will default the video quality to 360p (it does in my case).

YouTube Playback Settings

  • I was assuming the OP has an account and is logged in. – yassarikhan786 Sep 29 '13 at 14:04
  • @yassarikhan786 it's already turned on – Ashlie Sep 29 '13 at 16:56
  • Ok, try the other answer. – yassarikhan786 Sep 29 '13 at 16:57