For months I had been periodically tweeting questions at various public figures, and when I thought they didn't answer, I removed the tweet.

Now I've just discovered "Interactions" under "@Connect" on the Twitter site, and realised that they were replying all along, but I have no idea what my original questions were because I deleted them. (Which is really frustrating.)

What I don't understand is how this happened in the first place.

Why don't I get a notification informing me when someone has @replied to me? What am I missing here?


3 Answers 3


Before you deleted the tweets you would have checked the Interactions and Mentions tab for the replied tweets.

After you delete the original tweet to which other people have replied you cannot know which is the tweet which they have replied to.

This is the case as if in a forum the original thread which has been answered is deleted for which you only see the answers and not the question.

You cannot get notifications on Twitter (web) on the Connect tab unless you check it. Although you can set the email notifications on when someone mentions you on Twitter or replies to your tweet, or retweets your tweet, or favorites your tweet.

  • 1
    Why the #$^% can't I get a notification on the site itself? Dec 5, 2013 at 5:24
  • it's the way twitter is designed, you can be alerted by email and then login and check :)
    – plain jane
    Dec 5, 2013 at 5:37

For others who search here, consider your "Quality filter"

enter image description here

Under the navbar ... (more) | Settings ... | Notifications | Filters | Quality filter

From the help:

Quality filter, when turned on, filters lower-quality content from your notifications, for example, duplicate Tweets or content that appears to be automated — it does not filter notifications from people you follow or accounts you’ve recently interacted with.

: : :

EDIT: Nope that didn't help me. I'm still not getting notified when people reply to my replies, neither under Twitter Notifications, nor in email. Very frustrating.

Now trying more buried settings, in iPhone | Settings | Notifications | Twitter | Twitter Notification Settings | Mentions and replies | From anyone

enter image description here


Go to settings then notifications click filters then muted notifications make sure everything is turned off or not green

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.