4

When I use Trello at work, certain specific actions consistently fail to get persisted back to the server. The two that I am always having issues with are:

  • Removing labels
  • Deleting items from checklists

As an example, let's say I create a new card and assign label A. I then come back later and remove label A, but assign label B.

The outcome is at first an orange message in the top right corner:

Sending...

This is followed by a red message in the top right corner:

Connection interrupted. Retrying 1 action.

This message never goes away. If I refresh Trello, the card will have both labels A and B assigned.

My workaround at the moment is to open the Android app on my phone and remove the label.

I'm guessing this is related specifically to our work environment - the firewall, proxy, ISA server, etc. I have tried using Fiddler to see which specific HTTP requests are failing, but as soon as Fiddler is hooked in as a proxy all external web sites stop working.

My question is, does anyone know what is special about these specific actions and why they might be failing inside my work firewall?

Note - I don't believe this a bug in Trello as it works perfectly outside of work!

4

Both of the actions you described use the DELETE HTTP verb. Is your proxy blocking non-GET/POST/PUT requests?

Other things that use DELETE, for testing if this is in fact the root issue:

  • Removing a member from a card
  • Deleting a card
  • Removing a member from a board
  • Removing a vote from a card (requires the voting powerup to be enabled)
  • 1
    I think you've got it. I hardly ever delete cards, and don't really use members, so wouldn't have noticed these. I just added a member to a card successfully, and removing it threw up the same error! I'll see if our proxy can be changed. – Sir Crispalot Dec 18 '13 at 17:14
  • Our sysadmins have enabled an SSL tunnel through our proxy, and everything now works flawlessly. Thanks for your answer (and keep up the great work with Trello!) – Sir Crispalot Dec 19 '13 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.