I recently set up my primary Gmail account to serve as a central hub for a number of my old addresses. I added a number of filters to apply labels and force most messages to bypass the inbox.

I've noticed that I've been missing some of the emails forwarded from my old accounts. They are skipping the inbox and appearing in "All Mail" with no labels.

I'd imagine that one of my filters is forcing these messages to skip the inbox, but it seems odd that they are not getting a label as all of my filters are set to add a label.

I know I can see all filtered messages by going into the settings tab and editing an existing folder, but I was wondering if there was a more direct way to see what filters were applied to a given message.

It almost seems like Gmail is archiving every message that does not meet any of the various filter criteria.


I found the problem with my filters. My central account was set up to import emails from 5 addresses. I wanted to simplify the filter process, so I created dedicated emails for social networks and for gaming logins.

Rather than creating filters for emails from several places, I could create a single filter for emails to the social/gaming address. I did the same with my two work emails and my old personal email.

When importing my old personal email, I set the import up to skip the inbox initially because I knew all existing messages would come in as unread. I didn't want to clutter my inbox while I was setting up the filters and running the initial import.

By the time I finished setting everything up, I had forgotten about this setting.

To fix the problem, I had to edit the import settings for the address in question and turn off the option to skip the inbox.

I should have thought of this sooner.

  • Could you include an example of such an email, and maybe a list of your filter definitions? Dec 20, 2013 at 11:19
  • are you forwarding the email from the old accounts or are you telling gmail to pull them? Dec 20, 2013 at 13:42
  • @mhoran_psprep I am importing the other accounts. Thanks for asking this question. It helped me solve my problem. I had initially set up my old personal email to skip the inbox to avoid clutter when setting up the hub account. I forgot to turn that option off once everything was set up.
    – user55426
    Dec 20, 2013 at 14:30

2 Answers 2


Based on my addition to the initial question, I feel like the answer is no (sort of).

The emails in question were skipping the inbox due to a "hidden" filter in the import settings for that address. This filter was not visible in the Filters section of the settings, and it was not applying a label, so there was no "easy" way to track down what was causing the problem.

The easiest way to track down what filters get applied is simply to make sure that every single filter (even these "hidden" ones) applies a label. That way, the label will quickly tell you what filter gets applied.

That's an easy solution for filters created under settings, but not quite so easy for the filters tucked inside Gmails import settings for other addresses.


I would make sure filter properties are correct then view "skipped" messages to see which labels are applied - they are displayed next to the subject text & can be edited from the dropdown labels menu.

As you mentioned, you can also navigate to the settings tab.

  • The problem I have is that the messages in question aren't actually getting a label. (Despite all of my filters being set to add one). It seems like any email that didn't meet the criteria of a filter is snooping the inbox.
    – user55426
    Dec 20, 2013 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.