12

My boss has a business email address, say boss@job.com, and I have him listed in Gmail contacts under his name, say "John Doe." Now, apparently his wife has a Google+ account under the name "Mary Jane" where she used his work email address, boss@job.com, to register. So what does Gmail do If I want to compose an email to my boss? If I

  • try to type in "John Doe" into the to line, it does absolutely nothing; Gmail does not recognise this contact
  • try to type in John Doe's email address into the to line, it autocompletes as Mary Jane < boss@job.com >.

You might say, well that is his fault for sharing a Google+ account with is wife using his business email address, he should just live with getting emails addressed to "Marry Jane." If I were just sending emails to him this would be fine, but often I send emails to several people where he is CCed or where others are CCed and it's very strange for those other people to see "Mary Jane" in the to line. Note this problem existed prior to this whole Google+ controversy. Is there a solution to this problem that doesn't involve me telling my boss or boss's wife to do something?

  • This isn't even related to Google+ I don't think. I've seen the same thing when two contacts had the same email address (long before G+ existed). – ale Feb 8 '14 at 15:30
  • but the google plus person isn't in my contacts, nor in my google+ circles. – WetlabStudent Feb 8 '14 at 16:01
  • That is odd, then. Did you check in your "Other contacts" too? – ale Feb 8 '14 at 16:24
  • if I search other contacts for "Mary Jane" I get several contacts listed as "John Doe" but none listed as Mary Jane, and then it says on all these john doe contacts, connected profiles (with a google+ logo) Mary Jane – WetlabStudent Feb 8 '14 at 16:43
9

In the contact for John Doe, you need to add a nickname John Doe. Then you will be able to type John Doe in the To field, and the contact will show as John Doe instead of Mary Jane.

In other words, the names seem to take the following precedence:

  1. Nickname
  2. Google+ name
  3. Contact name

Stupid, I know, but at least it works.

  • 2
    The next question is: "how do I add a nickname?". The answer is: i nthe contact screen, under the address, there's an "Add" button. Click on it, find "nickname" on the list, click on it. That will add an input field under the person's job title/company, next to their picture. – msb Dec 18 '14 at 1:51
  • Unfortunately this does not appear to work anymore - Google+ is taking precedence over both the nickname and the name in the contacts. – Evan Pon May 10 '16 at 21:44
2

If the contact's email is a Gmail address, you can append a + to the email address in your contact list (so boss+@gmail.com if the address is boss@gmail.com). This will still reach the same mailbox, but will not be associated with the G+ account.

I tried the nickname trick, but that didn't work for me. Gmail still thought the G+ name is more accurate than anything that I'd written in my contacts list. What did work, however, was creating a contact with a + appended to the email address. (Info on why the plus sign works) This gave me a warning along the lines of: "Are you sure? This contact will not be associated with a public G+ account with a similar email." which of course was exactly what I wanted.

-1

I am not sure what you are asking for but you can always edit the name and email address before sending. I also suspect your "John Doe" is really the same as "John Joe" (typo?) in the top.

I would: 1. Confirm you have the correct name and e-mail address in your contacts list. Autofill pulls up matching names.

  1. Edit the name by clicking (or double click) on it if it shows "Mary Jane". You should be able to edit it as "John Doe " (without the quotes)

  2. GMail still lets you type in the full name and address so you do not have to select the suggested options it brings up. Enter the Firstname, Lastname, space, less than sign, email address, greater than sign.

Let us know how this resolves.

  • 1
    Well yes, I can just type everything by hand that does work, but I was hoping there was some way to fix the auto-complete instead – WetlabStudent Jan 12 '14 at 2:25
  • The more you use auto-complete, the better it works. You might have to hand type the address 3 - 4 times but it should eventually get it. – Kevan Sheridan Jan 12 '14 at 2:38
  • 1
    nope I've hand typed it like 30 times now. In this case gmail seems to think google+ is king – WetlabStudent Jan 12 '14 at 23:42
  • Maybe we need to back up some. What browser are you using? What steps can I take to duplicate the issue for me? Is "Mary Jane" listed in your contacts? In any Google+ Circle? – Kevan Sheridan Jan 13 '14 at 4:04
  • It happens in chrome, safari and firefox, and there is no one named "Mary Jane" in my google+ circles or in my contacts. – WetlabStudent Jan 13 '14 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.