7

For a number of months now, Gmail is constantly marking emails incorrectly as spam, and when I move them back into my inbox, it moves them back into spam again within an hour. It doesn't matter if I drag the emails to the inbox, or if I press the “Not spam” button, it moves them temporarily but then they go right back into the spam folder.

I login to Gmail almost exclusively using Google Chrome on a desktop PC, though I have also got it configured to work via IMAP with my Android phone, and Windows Live Mail on my home PC (that is rarely on).

There are two things that I think could have caused this:

  1. Allowing apps such as Mailstrom to access my Gmail, but access has since been removed via https://security.google.com/settings/security/permissions?pli=1 and I'm still having the same problem. Here are the apps that still have access: http://pastebin.com/CXXPXTMi

  2. I was so fed up with the situation I created a filter to move all of my spam into my inbox, but it didn't work. I have since removed the filter.

I've also tried sending all mail directly to the inbox using this filter with no luck - How can I remove spam filtering in Gmail?

Any suggestions please? This is making Gmail pretty much unusable right now, and whilst I'm tempted to migrate everything to Outlook.com, that is an absolute last resort for me.

4

Okay, this question is still getting a lot of views so I figure it's a good idea to post up the solution for my case at least.

What was happening, is regardless of my Gmail settings, Windows Live Mail was taking over and moving emails back into my spam, even if I used the "Never send to spam" filter as recommended by AI E.

To this this, I took the following steps:

  1. In Windows Live Mail click the Tools menu, and then click Junk e‑mail Options.

  2. Select the protection level you want. In my case I did No automatic filtering which just lets Gmail manage the spam folder entirely on it's own.

More info here: http://windows.microsoft.com/en-gb/windows-vista/block-spam-and-other-unwanted-e-mail

Hopefully other people find this useful too.

It sounds stupid but I just never thought for a second that Windows Live Mail would so aggressively manage my spam folder, particularly not to constantly move any mail back to the spam after I've flagged it as safe.

  • 1
    Microsoft Outlook will do this also. You can disable 'Junk E-mail protection...' to stop it from affecting new messages, but even this won't stop already marked messages from popping into your Spam. I additionally had to 'move' the already (mis-)marked messages from Junk to Inbox in Outlook. – sage Aug 25 '15 at 15:37
2

Removing the "spam" label and/or adding the "Inbox" label aren't enough to tell Gmail that the message isn't spam. You need to hit that "Not Spam" button. This is used as a signal for Google to improve its spam filters.

However, since you say you already use that button and message still get sent back to the spam label, something else is happening. Perhaps one or more of:

  1. Gmail has so many signals that a message is spam that it's overriding your "not spam" signal.
  2. A new message has come in on the conversation that is being marked as spam.
  3. One of the other apps that is accessing your mailbox is using its own signals for spam and is auto-marking them.

The Android Gmail app doesn't do that, but since you say you're using IMAP you must be using some other client. I don't recall if Mailstrom auto-marks any spam. Who knows what Windows Live Mail might be doing.

To troubleshoot, you probably need to disconnect your Gmail account from these other services and see if it still happens. If it doesn't, then re-connect one and see if it starts up again; then you'll have your culprit.

One thing that might help is to create a filter that will match most of these messages and use the "Never send to Spam" action.

  • Many thanks for the reply, 99% of the time I do use the 'Not spam' button, and the majority of messages are on their own and not part of a conversation. Thanks for the tip on ensuring they don't go to spam, I've tried that before with all mail but didn't have any joy: webapps.stackexchange.com/questions/22802/… By the way here is a list of services tied to my Google account, none seem to effect Gmail though pastebin.com/CXXPXTMi – Nick Jan 21 '14 at 14:22
  • 1
    Then it sounds like Gmail is bugging out on your account. You probably need direct support. Hit the "Gear", select "Help" then "Send Feedback". – ale Jan 21 '14 at 14:31
  • Thanks, I've done that a few times over the past ~6 months and not had a response yet :( – Nick Jan 21 '14 at 14:38
  • 1
    Then I'm afraid I'm out of suggestions. A new email provider might be your best bet. – ale Jan 21 '14 at 15:11
  • 1
    Have you tried adding the senders to your addressbook? – Itamar Jan 22 '14 at 7:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.