I sometimes double-click on a cell to see the formula or whatever, or I just accidentally start typing in the cell. How do I cancel the edits? Esc and Ctrl+Z don't work, so I typically hit Enter and then Ctrl+Z, but that seems clunky.

EDIT: Chrome on Ubuntu

  • 1
    Which browser are you using? In which version? Operating system?
    – StampedeXV
    Feb 27 '14 at 8:21

Wow, a year later I had this issue again. Finally realized that the issue was Vimium—once I disabled it on docs.google.com everything was fine. Seems kind of obvious, but for some reason I had figured that wasn't it. I guess I was unconsciously assuming I had already disabled Vimium in Google Docs because everything else worked.

  • 1
    Wow, very nice to figure out this little bastard haha. Would never have find the solution. Great! Aug 14 '17 at 21:28
  • 2
    Confirmed. This is Vimium and has plagued me for years.
    – Still.Tony
    Apr 28 '19 at 23:48
  • 2
    Just came across this. I was trying in different browsers thinking it was related to that, not realizing that I had Vimium installed in both!
    – aardvarkk
    Nov 28 '19 at 22:08
  • This has been bugging me for a while. Thank you!
    – armandino
    Dec 17 '19 at 20:05
  • I've removed Vimium - more trouble than it was worth to me. I tried adding Vimium rules to allow Google Sheets to operate as normal but didn't find a way. Nov 8 '20 at 14:37

I do the same as in Excel - pressing ESC works fine. Both in the new Google Sheets and the "normal" ones.

I use Chrome Version 33.0.1750.117 m

  • I tried ESC many times at the time, and it didn't work, but it works now, so I'm accepting your answer so this question doesn't stay open. Mar 1 '14 at 20:17

ESC should work. If it doesn't, try switching to a different browser.


I have the same issue: ESC does not work. I am on Chrome Version 56 (64 bit) on a macOS12.10 The only alternative I've found is CMD-Z after hitting ENTER.


Just a sidenote: This issue has been irritating me endlessly (using Safari on OSX) especially when working in Full screen mode (as one tends to do with large spreadsheets): ESC, instead of exiting cell edit, exits full screen.

It finally annoyed me enough that I forgot why I ever switched to Safari, so today I switched back to Chrome and it works just fine (ESC - as it should - exits the cell edit and I'm still in full screen).


After adding Google Spreadsheets as an exception in Vimium, everything works fine finally!

  • 3
    This doesn't offer any information not already found in the accepted answer.
    – ale
    Apr 24 '18 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.