35

Recently (maybe since a week ago), CNN.com started autoplaying videos. When I click on an article that has a video, the video automatically starts playing. Is there a way to disable this feature? I did not see any options to do so. I still want the option of playing the video manually.

  • You should be able to that by setting a configuration option of your browser. Depending on your browser, there are plugins available. I don't think there's an option within the CNN website. – pritaeas Mar 18 '14 at 13:57
  • 2
    To stop autoplay of HTML5 videos in Firefox: go to about:config and set media.autoplay.enabled to false – inanutshellus Jan 7 '16 at 14:42
  • I've changed that autoplay.enabled = false in the past and few months later I was super frustrated why slack.com (a chat web app that offer audio chatting) wasn't working for me. I realized by pure luck that it was because that change I made. bottom line is turning this off can break other websites that you may need! – Ramast Mar 28 '16 at 22:12
  • 1
    I am new here so it seems I have to put the solution in a comment: A) Disabling flash no longer helps, I don't even have flash installed and CNN just use HTML5 B) I have made greasemonkey script tinyurl.com/h6b22rc (if you are firefox user) that would find all html videos on the page and remove all autoplay, buffering attributes but again cnn auto re-start the video if it didn't play the first time. C) Last the solution that really worked for me was blocking this domain pmd.cdn.turner.com by adding the line 127.0.0.1 pmd.cdn.turner.com to my /etc/hosts file – Ramast Mar 28 '16 at 22:26
  • 2
    Also, the Disable HTML5 Autoplay extension for Chrome (chrome.google.com/webstore/detail/disable-html5-autoplay/…) stops the autoplayback cold in its tracks. – Juan Jimenez Feb 19 '17 at 10:40
21

I did the following for Google Chrome which does the job:

Settings → Show Advanced Settings → Content settings... → Plug-ins → Manage exceptions...

Then create a new exception as

[*.]cnn.com
[*.]turner.com

and make the behavior "Ask" (or "Block" in recent builds).

This will make it such that when you open a CNN article, you have to click the video to run Flash player, which effectively keeps it from auto-playing.

Edit: Dropped the "www" from the exception as putting just "cnn.com" will also block video on adjacent cnn websites like money.cnn.com

  • 3
    Chrome no longer has the "Ask" option in Plugins > Manage Exceptions. Instead, choose "Block". You can still right click to play the blocked flash video. – wisbucky Aug 1 '15 at 4:42
  • See @Ramast's comment above regarding the more recent necessity to block turner.com. – MrWhite Jul 15 '16 at 11:04
  • 1
    Chrome: This plugin worked for me : chrome.google.com/webstore/detail/disable-html5-autoplay/… – Sajjan Sarkar Feb 2 '17 at 21:28
  • if someone uses add block the following filter worked for me ||cnn.com/*/video . you can add them in ad block settings, filters, add filter. – awm May 12 '17 at 17:44
  • This is obsolete – Gert van den Berg Sep 8 '17 at 7:44
9

I wrote to CNN today to ask if there is a way to turn off autoplay, possibly by logging in and setting it in a preference. Here is the reply:

Thanks for contacting CNN. We do not offer the ability to disable the auto-play feature of the video and we appreciate you taking the time to voice your opinion. I will make sure this information is escalated and shared with the appropriate department for consideration.

I tried changing the Chrome setting to require a click before a plug-in is loaded (per the instructions above) but that also disables the still image, which is sometimes part of the story.

So I guess I'll be switching to MSNBC.COM...

  • 2
    "We appreciate you taking the time to voice your opinion" because it means somebody is actually viewing our site. "I will make sure this information is ... shared with appropriate department" so we can all sit down and laugh at you together. Anyone on the PLANET who believes people actually want autoplay that can't be turned off ... is either a brainless decerebrated hulk, or an asshole. – Ross Presser Oct 21 '15 at 4:59
  • 2
    +1 for contacting CNN. Unfortunately, their reply makes them look like asshats. – ThomasW Apr 21 '16 at 1:52
3

I installed No Script which is a must given all the cookies flying around out there...works with Firefox. You choose what comes in and what doesn't.

  • Install No Script add on for Firefox
  • Block turner.com
  • Voila, no vids.
  • did that - worked. there was a loading animation - got rid of it by also blocking cnn.io. (this autoplay "feature" is so utterly terrible) – Raffael Sep 7 '17 at 13:38
1

I've done a lot of basic searching for an answer to stop annoying autoplay video, particularly from CNN.COM. I could not find a reliable way to do so on IE11. However, I did find how to do that on Chrome. So, I've switched. Just go to Settings, Advanced, Privacy, Content Settings and review those options.

Chrome, I've avoided until now. A setting is how it ought to be. Not a 3rd party app. Bye-bye IE11.

0

In Firefox, you can go to Menu > Addons > Plugins > Shockwave Flash. Set it to Ask to Activate. That will make Flash disabled by default, and you can click it to activate it. (This will affect all websites, you can't filter which ones).

protected by Community Jul 25 '14 at 16:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.