When using a symbol such as unicode elment of ∈, subset of ⊆, etc., which does not appear in standard windows fonts the PPT exported file contains blank squares instead of the font. I expected the importer to automatically replace the character with an equivalent font from the windows "Symbol" fonts, so that the presentation will be viewable. In fact this is exactly what I did, by hand.

Any better workaround for that than replacing badly displayed symbols by hand?


The problem here is not google-docs export of the file, it's the fonts Power Point is using to display the file. A "blank box" like you describe is the standard windows response when the font it's asked to use doesn't have the character you asked it to render. Some apps will detect that and automatically switch fonts to one that does, I'm pretty sure Power Point is not one of them. I've seen similar behavior in the past and just taking the same .ppt file to a different system that had better fonts installed, or a different application that did a better job of picking a font solved it.

  • Then why is it, that when I'm inserting the special characters through MS power point everything works? (on the same system, the ppt file I edited with Power Point and inserted symbols through powerpoint works and the one exported don't. Jan 28 '11 at 7:00
  • Power Point changes the font when you do that. So you might have a dozen characters in Arial, then one in Symbol, then back to Arial for a bunch more. Google docs on the other hand will just tag the whole string as "sans serif" and put all the characters as one string. That works on the web and a variety of other apps because they intelligently map "sans serif" to a variety of fonts depending on what characters they need.
    – cabbey
    Jan 28 '11 at 17:36

I had no problem exporting a file with either of those two characters. I also tried Omega and other big-O notation characters. All seemed to work. Is it possible that the problem has been fixed on the server side?

  • It might be fixed. Did you export to ppt` file? Oct 2 '10 at 17:22

Please note that some applications are inserting fonts using proprietary non-standard symbol fonts, such as Symbol.ttf and Windings. these fonts doesn't map the technical symbols into the right unicode characters, which makes it break if the font is not installed on your system, if people are doing copy-paste operations without manually changing the fonts, as well as on applications which doesn't support 3rd party fonts.

The best solution I know is to manually go over the files and replace these characters with their Unicode equivalents.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.