I've looked at several forums like this one and this one but since Google changes their interface every couple days, they're all wrong.

Here's what my sign in page looks like today and I can't remove any of the accounts from the list:

First I go to gmail.com and get this:

enter image description here

Then I click Sign in with a different account and get this:

enter image description here

  • There should be "remove account" on the sign-in page next to "add account". Where is this screenshot from? A sign in page or an account page? Apr 14, 2014 at 13:11
  • @Raystafarian I updated the question to show how I got there
    – Okuma.Tony
    Apr 14, 2014 at 13:20
  • What browser are you using? Do you have any extensions on it? It seems like what you should see is being removed or blocked. Apr 14, 2014 at 13:21
  • @Raystafarian Google Chrome, Windows 7 64b, no extensions
    – Okuma.Tony
    Apr 14, 2014 at 13:22
  • 1
    I see the same as the OP. There was no Remove account button but it appeared when I logged out of one of the Google accounts that I was logged into. Nov 17, 2014 at 20:39

3 Answers 3


Make sure you go to google.com not google.ext (where ext is from your country).

From there log out from all listed accounts, and on the login windows, choose log in with other account.

This should give you this:

enter image description here

If you don't see the above at this point even, clear your browsercache, temporary internet files and cookies. Then try again.

  • 4
    I'm in the US going to google.com. I logged in and out and remove was there. I'm highly perturbed that this worked. Makes no sense at all.
    – Okuma.Tony
    Apr 14, 2014 at 13:27
  • My guess is that the view without "remove" is when an application requested for logging through your Google account.
    – lukstafi
    May 17, 2014 at 23:42
  • 4
    Terrible UI design by Google... what a convoluted way to even get to this screen!
    – Noldorin
    Jun 28, 2016 at 0:55
  • 1
    To clarify, when you have multiple accounts in the list, you must sign out of ALL accounts for the "Remove" button to show up. That took me a while to figure out. Feb 21, 2017 at 16:49
  • 1
    @BrianMoeskau thanks for the inforation. I've edited the post accordingly.
    – LPChip
    Feb 21, 2017 at 17:37

You can make the Remove account button appear by logging out of one of the Google accounts that you are logged into.

  • 1
    You have to log out of ALL accounts, not just one of them. Feb 21, 2017 at 16:50
  • 2
    was able to make it appear by logging out of only one account Aug 16, 2018 at 14:19

If you want to disable the entire system, not just remove a particular account, go to this page


Scroll down until you see a button that says “Disable Account Chooser”. After you click it, Gmail won't remember the accounts that have logged in (except if your browser fills in fields, but that's another mechanism). Basically, you are back where you were before Google "improved" Gmail with this chooser thing.

To be fair, it's a useful feature for many cases, but terrible for shared computers.

  • 1
    I wanted this to work, and I assume it did once, but no more.
    – Amanda
    Nov 8, 2017 at 17:52
  • It still works for me... maybe try disabling and re-enabling? I'm using Firefox v 56.0
    – pgr
    Nov 9, 2017 at 19:45
  • Still works for me. Thanks
    – arslion
    Apr 3, 2018 at 12:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.